lpget - get printing configuration
lpget [-k key] [destination... | list]
The lpget utility reads printing configuration information from the
configuration databases in $HOME/.printers, /etc/printers.conf,
and printers.conf.byname. This information, called a configuration
report, is displayed to the standard output. See printers(5) and
printers.conf(5) for information about the printer configuration
lpget displays a configuration report for all keys for the
specified destination or destinations by default. Use the -k option
to display a configuration report for specific keys. Use the list
operand to display a configuration report for all configured
The following option is supported:
The following operands are supported:
Displays a configuration report for key
for information about specifying key
Displays a configuration report for destination
Destination can be either a printer of a class of printers. See
. Specify destination
using atomic or POSIX-style
) names. See printers.conf(5)
for information regarding the naming conventions for atomic names and
for information concerning POSIX.
Displays a configuration report for all configured
Example 1 Displaying a Configuration Report for the bsdaddr Key
The following example displays a configuration report for the
bsdaddr key for printer catalpa.
example% lpget -k bsdaddr catalpa
Example 2 A Configuration Report for all Keys for all
The following example displays a configuration report for all keys
for all configured destinations.
example% lpget list
The following exit values are returned:
An error occurred.
System printer configuration database.
User-configurable printer database.
NIS version of /etc/printers.conf.
See attributes(7) for descriptions of the following attributes:
ldap(1), lp(1), lpstat(1), lpc(1B), lpq(1B),
lpr(1B), printers(5), printers.conf(5),
attributes(7), standards(7), lpadmin(8), lpset(8)
Be mindful of the following if the LDAP database is used as the name service. If
the ldapclient(8) server is a replica LDAP server, LDAP printer
database updates may not appear immediately, as the replica server may not not
have been updated by the master server and can be out of sync. For example, a
printer that you deleted by using lpset(8) may still appear in the
printer list you display with lpget until the replica is updated from
the master. Replica servers vary as to how often they are updated from the
master. Refer to the for more information on LDAP replication.