|PKGADM(8)||Maintenance Commands and Procedures||PKGADM(8)|
pkgadm - manage packaging system
pkgadm dbstatus [-R rootpath]
pkgadm sync [-R rootpath] [-q]
The pkgadm utility is used for managing the packaging system. It has several subcommands that perform various operations relating to packaging.
The Solaris operating system relies upon enhanced System V revision 4 (SVr4) packages as the basis for its software installation and revision management. The package maintenance software stores information about installed packages in an internal database. The pkgadm subcommand dbstatus is used to determine how the package internal database is implemented. The dbstatus command returns a string that indicates the type of internal database in use. In the current implementation, the dbstatus command always returns the string text, which indicates that the contents(5) package database is in use. Future releases of Solaris might supply alternative database implementations.
The following options are supported:
Example 1 Synchronizing the contents file
The following example forces any pending changes to the contents(5) file to be flushed and the pkgserv daemon to shut down.
example% pkgadm sync -q
See attributes(7) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
pkginfo(1), pkgmk(1), pkgparam(1), pkgproto(1), pkgtrans(1), svcs(1), admin(5), contents(5), exec_attr(5), pkginfo(5), attributes(7), rbac(7), smf(7), installf(8), pkgadd(8), pkgask(8), pkgrm(8), removef(8), svcadm(8)
The service for pkgadm is managed by the service management facility, smf(7), under the service identifier:
|March 2, 2017||OmniOS|