IFCONFIG(8) | Maintenance Commands and Procedures | IFCONFIG(8) |
ifconfig - configure network interface parameters
ifconfig interface [address_family] [address [/prefix_length]
[dest_address]] [addif address [/prefix_length]]
[removeif address [/prefix_length]] [arp | -arp]
[auth_algs authentication algorithm] [encr_algs encryption algorithm]
[encr_auth_algs authentication algorithm] [auto-revarp]
[broadcast address] [deprecated | -deprecated]
[preferred | -preferred] [destination dest_address]
[ether [address]] [failover | -failover] [group
[name | ""]] [index if_index] [ipmp] [metric n] [modlist]
[modinsert mod_name@pos] [modremove mod_name@pos]
[mtu n] [netmask mask] [plumb] [unplumb] [private
| -private] [nud | -nud] [set [address] [/netmask]]
[standby | -standby] [subnet subnet_address] [tdst
tunnel_dest_address] [token address/prefix_length]
[tsrc tunnel_src_address] [trailers | -trailers]
[up] [down] [usesrc [name | none]] [xmit | -xmit]
[encaplimit n | -encaplimit] [thoplimit n] [router
| -router] [zone zonename | -zone | -all-zones]
ifconfig [address_family] interface {auto-dhcp | dhcp} [primary]
[wait seconds] drop | extend | inform | ping
| release | start | status
The command ifconfig is used to assign an address to a network interface and to configure network interface parameters. The ifconfig command must be used at boot time to define the network address of each interface present on a machine; it may also be used at a later time to redefine an interface's address or other operating parameters. If no option is specified, ifconfig displays the current configuration for a network interface. If an address family is specified, ifconfig reports only the details specific to that address family. Only privileged users may modify the configuration of a network interface. Options appearing within braces ({}) indicate that one of the options must be specified.
Network interface observability with ifconfig is limited to those network interfaces that have been prepared for use with the IP protocol suite. The preferred method for configuring a network interface for use with TCP/IP is with ipadm and alternatively with the use of the plumb option as documented below. Network interfaces that have not been configured for use with the IP protocol suite can only be observed by using the dladm command.
The forms of ifconfig that use the auto-dhcp or dhcp arguments are used to control the Dynamic Host Configuration Protocol ("DHCP") configuration of the interface. In this mode, ifconfig is used to control operation of dhcpagent(8), the DHCP client daemon. Once an interface is placed under DHCP control by using the start operand, ifconfig should not, in normal operation, be used to modify the address or characteristics of the interface. If the address of an interface under DHCP is changed, dhcpagent will remove the interface from its control.
When the ifconfig command is executed without any options its behavior is the same as when the -a option is supplied with no other options or arguments.
The following options are supported:
addif address
all-zones
The tnzonecfg database is described in the tnzonecfg(5) man page, which is part of the Solaris Trusted Extensions Reference Manual.
anycast
-anycast
arp
-arp
auth_algs authentication algorithm
It is now preferable to use the ipsecconf(8) command when configuring a tunnel's security properties. If ipsecconf was used to set a tunnel's security properties, this keyword will not affect the tunnel.
auto-dhcp
For IPv6, the interface specified must be the zeroth logical interface (the physical interface name), which has the link-local address.
primary
wait seconds
drop
extend
inform
ping
release
start
status
auto-revarp
broadcast address
example% ifconfig -a netmask + broadcast +
and
example% ifconfig -a broadcast + netmask +
may result in different values being assigned for the broadcast addresses of the interfaces.
deprecated
-deprecated
preferred
-preferred
destination dest_address
dhcp
down
When a logical interface is down, all routes that specify that interface as the output (using the -ifp option in the route(8) command or RTA_IFP in a route(4P) socket) are removed from the forwarding table. Routes marked with RTF_STATIC are returned to the table if the interface is brought back up, while routes not marked with RTF_STATIC are simply deleted.
When all logical interfaces that could possibly be used to reach a particular gateway address are brought down (specified without the interface option as in the previous paragraph), the affected gateway routes are treated as though they had the RTF_BLACKHOLE flag set. All matching packets are discarded because the gateway is unreachable.
encaplimit n
This option is obsolete, superseded by the dladm(8) encaplimit link property.
-encaplimit
This option is obsolete, superseded by the dladm(8) encaplimit link property.
encr_auth_algs authentication algorithm
It is now preferable to use the ipsecconf(8) command when configuring a tunnel's security properties. If ipsecconf was used to set a tunnel's security properties, this keyword will not affect the tunnel.
encr_algs encryption algorithm
It is now preferable to use the ipsecconf(8) command when configuring a tunnel's security properties. If ipsecconf was used to set a tunnel's security properties, this keyword will not affect the tunnel.
ether [ address ]
Otherwise, if the user is root or has sufficient privileges, set the Ethernet address of the interfaces to address. The address is an Ethernet address represented as x:x:x:x:x:x where x is a hexadecimal number between 0 and FF. Similarly, for the IPoIB (IP over InfiniBand) interfaces, the address will be 20 bytes of colon-separated hex numbers between 0 and FF.
Some, though not all, Ethernet interface cards have their own addresses. To use cards that do not have their own addresses, refer to section 3.2.3(4) of the IEEE 802.3 specification for a definition of the locally administered address space. Note that all IP interfaces in an IPMP group must have unique hardware addresses; see in.mpathd(8).
-failover
failover
group [ name |""]
When applied to a physical IPMP IP interface, it renames the IPMP group to have the new name. If the name already exists, or a name of "" is specified, it fails. Renaming IPMP groups is discouraged. Instead, the IPMP IP interface should be given a meaningful name when it is created by means of the ipmp subcommand, which the system will also use as the IPMP group name.
index n
ipmp
metric n
modinsert mod_name@pos
Based upon the example in the modlist option, use the following command to insert a module with name ipqos under the ip module and above the firewall module:
example% ifconfig eri0 modinsert ipqos@2
A subsequent listing of all the modules in the stream of the device follows:
example% ifconfig eri0 modlist 0 arp 1 ip 2 ipqos 3 firewall 4 eri
modlist
The following example lists all the modules in the stream of the device:
example% ifconfig eri0 modlist 0 arp 1 ip 2 firewall 4 eri
modremove mod_name@pos
Based upon the example in the modinsert option, use the following command to remove the firewall module from the stream after inserting the ipqos module:
example% ifconfig eri0 modremove firewall@3
A subsequent listing of all the modules in the stream of the device follows:
example% ifconfig eri0 modlist 0 arp 1 ip 2 ipqos 3 eri
Note that the core IP stack modules, for example, ip and tun modules, cannot be removed.
mtu n
netmask mask
If a pseudo host name/pseudo network name is supplied as the netmask value, netmask data may be located in the hosts or networks database. Names are looked up by first using gethostbyname(3NSL). If not found there, the names are looked up in getnetbyname(3SOCKET). These interfaces may in turn use nsswitch.conf(5) to determine what data store(s) to use to fetch the actual value.
For both inet and inet6, the same information conveyed by mask can be specified as a prefix_length attached to the address parameter.
nud
-nud
plumb
An interface must be separately plumbed for IPv4 and IPv6 according to the address_family parameter (IPv4 if unspecified). Before an interface has been plumbed, it will not be shown by ifconfig -a.
Note that IPMP IP interfaces are not tied to a specific datalink and are instead created with the ipmp subcommand.
private
-private
removeif address
router
-router
set
standby
-standby
subnet
tdst tunnel_dest_address
This option is obsolete, superseded by the dladm(8) create-iptun and modify-iptun subcommands.
thoplimit n
This option is obsolete, superseded by the dladm(8) hoplimit link property.
token address/prefix_length
example% ifconfig eri0 inet6 token ::1/64
trailers
-trailers
tsrc tunnel_src_address
This option is obsolete, superseded by the dladm(8) create-iptun and modify-iptun subcommands.
unplumb
An interface must be separately unplumbed for IPv4 and IPv6 according to the address_family parameter (IPv4 if unspecified). Upon success, the interface name will no longer appear in the output of ifconfig -a.
up
usesrc [ name | none ]
When an application does not choose a non-zero source address using bind(3SOCKET), the system will select an appropriate source address based on the outbound interface and the address selection rules (see ipaddrsel(8)).
When usesrc is specified and the specified interface is selected in the forwarding table for output, the system looks first to the specified physical interface and its associated logical interfaces when selecting a source address. If no usable address is listed in the forwarding table, the ordinary selection rules apply. For example, if you enter:
# ifconfig eri0 usesrc vni0
...and vni0 has address 10.0.0.1 assigned to it, the system will prefer 10.0.0.1 as the source address for any packets originated by local connections that are sent through eri0. Further examples are provided in the EXAMPLES section.
While you can specify any physical interface (or even loopback), be aware that you can also specify the virtual IP interface (see vni(4D)). The virtual IP interface is not associated with any physical hardware and is thus immune to hardware failures. You can specify any number of physical interfaces to use the source address hosted on a single virtual interface. This simplifies the configuration of routing-based multipathing. If one of the physical interfaces were to fail, communication would continue through one of the remaining, functioning physical interfaces. This scenario assumes that the reachability of the address hosted on the virtual interface is advertised in some manner, for example, through a routing protocol.
Because the ifconfig preferred option is applied to all interfaces, it is coarser-grained than the usesrc option. It will be overridden by usesrc and setsrc (route subcommand), in that order.
IPMP and the usesrc option are mutually exclusive. That is, if an interface is part of an IPMP group or marked STANDBY, then it cannot be specified by means of usesrc, and vice-versa.
xmit
-xmit
zone zonename
-zone
The interface operand, as well as address parameters that affect it, are described below.
interface
-a
-d
-D
-u
-Z
-4
-6
address_family
ifconfig honors the DEFAULT_IP setting in the /etc/default/inet_type file when it displays interface information. If DEFAULT_IP is set to IP_VERSION4, then ifconfig will omit information that relates to IPv6 interfaces. However, when you explicitly specify an address family (inet or inet6) on the ifconfig command line, the command line overrides the DEFAULT_IP settings.
address
For the IPv6 family (inet6), the address is either a host name present in the host name data base (see hosts(5)) or in the Network Information Service (NIS) map ipnode, or an IPv6 address expressed in the Internet standard colon-separated hexadecimal format represented as x:x:x:x:x:x:x:x where x is a hexadecimal number between 0 and FFFF.
prefix_length
dest_address
tunnel_dest_address
tunnel_src_address
The ifconfig command supports the following interface flags. The term "address" in this context refers to a logical interface, for example, eri0:0, while "interface" refers to the physical interface, for example, eri0.
ADDRCONF
ANYCAST
BROADCAST
CoS
Note that this flag is only set on interfaces over VLAN links and over Ethernet links that have their dladm(8) tagmode link property set to normal.
DEPRECATED
DHCPRUNNING
DUPLICATE
FAILED
FIXEDMTU
INACTIVE
IPMP
LOOPBACK
MULTI_BCAST
MULTICAST
NOARP
NOFAILOVER
NOLOCAL
NONUD
NORTEXCH
NOXMIT
OFFLINE
POINTOPOINT
PREFERRED
PRIVATE
PROMISC
ROUTER
RUNNING
STANDBY
TEMPORARY
UNNUMBERED
UP
VIRTUAL
XRESOLV
Solaris TCP/IP allows multiple logical interfaces to be associated with a physical network interface. This allows a single machine to be assigned multiple IP addresses, even though it may have only one network interface. Physical network interfaces have names of the form driver-name physical-unit-number, while logical interfaces have names of the form driver-name physical-unit-number:logical-unit-number. A physical interface is configured into the system using the plumb command. For example:
example% ifconfig eri0 plumb
Once a physical interface has been "plumbed", logical interfaces associated with the physical interface can be configured by separate -plumb or -addif options to the ifconfig command.
example% ifconfig eri0:1 plumb
allocates a specific logical interface associated with the physical interface eri0. The command
example% ifconfig eri0 addif 192.168.200.1/24 up
allocates the next available logical unit number on the eri0 physical interface and assigns an address and prefix_length.
A logical interface can be configured with parameters (address, prefix_length, and so on) different from the physical interface with which it is associated. Logical interfaces that are associated with the same physical interface can be given different parameters as well. Each logical interface must be associated with an existing and "up" physical interface. So, for example, the logical interface eri0:1 can only be configured after the physical interface eri0 has been plumbed.
To delete a logical interface, use the unplumb or removeif options. For example,
example% ifconfig eri0:1 down unplumb
will delete the logical interface eri0:1.
Physical interfaces that share the same link-layer broadcast domain must be collected into a single IP Multipathing (IPMP) group using the group subcommand. Each IPMP group has an associated IPMP IP interface, which can either be explicitly created (the preferred method) by using the ipmp subcommand or implicitly created by ifconfig in response to placing an IP interface into a new IPMP group. Implicitly-created IPMP interfaces will be named ipmpN where N is the lowest integer that does not conflict with an existing IP interface name or IPMP group name.
Each IPMP IP interface is created with a matching IPMP group name, though it can be changed using the group subcommand. Each IPMP IP interface hosts a set of highly-available IP addresses. These addresses will remain reachable so long as at least one interface in the group is active, where "active" is defined as having at least one UP address and having INACTIVE, FAILED, and OFFLINE clear. IP addresses hosted on the IPMP IP interface may either be configured statically or configured through DHCP by means of the dhcp subcommand.
Interfaces assigned to the same IPMP group are treated as equivalent and monitored for failure by in.mpathd. Provided that active interfaces in the group remain, IP interface failures (and any subsequent repairs) are handled transparently to sockets-based applications. IPMP is also integrated with the Dynamic Reconfiguration framework (see cfgadm(8)), which enables network adapters to be replaced in a way that is invisible to sockets-based applications.
The IP module automatically load-spreads all outbound traffic across all active interfaces in an IPMP group. Similarly, all UP addresses hosted on the IPMP IP interface will be distributed across the active interfaces to promote inbound load-spreading. The ipmpstat(8) utility allows many aspects of the IPMP subsystem to be observed, including the current binding of IP data addresses to IP interfaces.
When an interface is placed into an IPMP group, any UP logical interfaces are "migrated" to the IPMP IP interface for use by the group, unless:
Likewise, once an interface is in a group, if changes are made to a logical interface such that it is UP and not exempted by one of the conditions above, it will also migrate to the associated IPMP IP interface. Logical interfaces never migrate back, even if the physical interface that contributed the address is removed from the group.
Each interface placed into an IPMP group may be optionally configured with a "test" address that in.mpathd will use for probe-based failure detection; see in.mpathd(8). These addresses must be marked NOFAILOVER (using the -failover subcommand) prior to being marked UP. Test addresses may also be acquired through DHCP by means of the dhcp subcommand.
For more background on IPMP, please see the IPMP-related chapters of the System Administration Guide: Network Interfaces and Network Virtualization.
When an IPv6 physical interface is plumbed and configured "up" with ifconfig, it is automatically assigned an IPv6 link-local address for which the last 64 bits are calculated from the MAC address of the interface.
example% ifconfig eri0 inet6 plumb up
The following example shows that the link-local address has a prefix of fe80::/10.
example% ifconfig eri0 inet6 ce0: flags=2000841<UP,RUNNING,MULTICAST,IPv6>
mtu 1500 index 2 inet6 fe80::a00:20ff:fe8e:f3ad/10
Link-local addresses are only used for communication on the local subnet and are not visible to other subnets.
If an advertising IPv6 router exists on the link advertising prefixes, then the newly plumbed IPv6 interface will autoconfigure logical interface(s) depending on the prefix advertisements. For example, for the prefix advertisement 2001:0db8:3c4d:0:55::/64, the autoconfigured interface will look like:
eri0:2: flags=2080841<UP,RUNNING,MULTICAST,ADDRCONF,IPv6>
mtu 1500 index 2
inet6 2001:0db8:3c4d:55:a00:20ff:fe8e:f3ad/64
Even if there are no prefix advertisements on the link, you can still assign global addresses manually, for example:
example% ifconfig eri0 inet6 addif \ 2001:0db8:3c4d:55:a00:20ff:fe8e:f3ad/64 up
To configure boot-time defaults for the interface eri0, place the following entry in the /etc/hostname6.eri0 file:
addif 2001:0db8:3c4d:55:a00:20ff:fe8e:f3ad/64 up
An IP tunnel is conceptually comprised of two parts: a virtual link between two or more IP nodes, and an IP interface above this link which allows the system to transmit and receive IP packets encapsulated by the underlying link.
The dladm(8) command is used to configure tunnel links, and ifconfig is used to configure IP interfaces over those tunnel links. An IPv4-over-IPv4 tunnel is created by plumbing an IPv4 interface over an IPv4 tunnel link. An IPv6-over-IPv4 tunnel is created by plumbing an IPv6 interface over an IPv6 tunnel link, and so forth.
When IPv6 interfaces are plumbed over IP tunnel links, their IPv6 addresses are automatically set. For IPv4 and IPv6 tunnels, source and destination link-local addresses of the form fe80::interface-id are configured. For IPv4 tunnels, the interface-id is the IPv4 tunnel source or destination address. For IPv6 tunnels, the interface-id is the last 64 bits of the IPv6 tunnel source or destination address. For example, for an IPv4 tunnel between 10.1.2.3 and 10.4.5.6, the IPv6 link-local source and destination addresses of the IPv6 interface would be fe80::a01:203 and fe80::a04:506. For an IPv6 tunnel between 2000::1234:abcd and 3000::5678:abcd, the IPv6 link-local source and destination addresses of the interface would be fe80::1234:abcd and fe80::5678:abcd. These default link-local addresses can be overridden by specifying the addresses explicitly, as with any other point-to-point interface.
For 6to4 tunnels, a 6to4 global address of the form 2002:tsrc::1/16 is configured. The tsrc portion is the tunnel source IPv4 address. The prefix length of the 6to4 interface is automatically set to 16, as all 6to4 packets (destinations in the 2002::/16 range) are forwarded to the 6to4 tunnel interface. For example, for a 6to4 link with a tunnel source of 75.1.2.3, the IPv6 interface would have an address of 2002:4b01:203::1/16.
Additional IPv6 addresses can be added using the addif option or by plumbing additional logical interfaces.
For backward compatibility, the plumbing of tunnel IP interfaces with special names will implicitly result in the creation of tunnel links without invoking dladm create-iptun. These tunnel names are:
ip.tunN
ip6.tunN
ip.6to4tunN
These tunnels are "implicit tunnels", denoted with the i flag in dladm show-iptun output. The tunnel links over which these special IP interfaces are plumbed are automatically created, and they are automatically deleted when the last reference is released (that is, when the last IP interface is unplumbed).
The tsrc, tdst, encaplim, and hoplimit options to ifconfig are obsolete and maintained only for backward compatibility. They are equivalent to their dladm(8) counterparts.
The ifconfig output for IP tunnel interfaces indicates whether IPsec policy is configured for the underlying IP tunnel link. For example, a line of the following form will be displayed if IPsec policy is present:
tunnel security settings --> use 'ipsecconf -ln -i ip.tun1'
If you do net set security policy, using either ifconfig or ipsecconf(8), there is no tunnel security setting displayed.
Example 1 Using the ifconfig Command
If your workstation is not attached to an Ethernet, the network interface, for example, eri0, should be marked "down" as follows:
example% ifconfig eri0 down
Example 2 Printing Addressing Information
To print out the addressing information for each interface, use the following command:
example% ifconfig -a
Example 3 Resetting the Broadcast Address
To reset each interface's broadcast address after the netmasks have been correctly set, use the next command:
example% ifconfig -a broadcast +
Example 4 Changing the Ethernet Address
To change the Ethernet address for interface ce0, use the following command:
example% ifconfig ce0 ether aa:1:2:3:4:5
Example 5 Configuring an IP-in-IP Tunnel
To configure an IP-in-IP tunnel, first create an IP tunnel link (tunsrc and tundst are hostnames with corresponding IPv4 entries in /etc/hosts):
example% dladm create-iptun -T ipv4 -s tunsrc -d tundst tun0
Then plumb a point-to-point interface, supplying the source and destination addresses (mysrc and thedst are hostnames with corresponding IPv4 entries in /etc/hosts):
example% ifconfig tun0 plumb mysrc thedst up
Use ipsecconf(8), as described above, to configure tunnel security properties.
Configuring IPv6 tunnels is done by using a tunnel type of ipv6 with create-iptun. IPv6 interfaces can also be plumbed over either type of tunnel.
Example 6 Configuring 6to4 Tunnels
To configure 6to4 tunnels, first create a 6to4 tunnel link (myv4addr is a hostname with a corresponding IPv4 entry in /etc/hosts):
example% dladm create-iptun -T 6to4 -s myv4addr my6to4tun0
Then an IPv6 interface is plumbed over this link:
example% ifconfig my6to4tun0 inet6 plumb up
The IPv6 address of the interface is automatically set as described above.
Example 7 Configuring IP Forwarding on an Interface
To enable IP forwarding on a single interface, use the following command:
example% ifconfig eri0 router
To disable IP forwarding on a single interface, use the following command:
example% ifconfig eri0 -router
Example 8 Configuring Source Address Selection Using a Virtual Interface
The following command configures source address selection such that every packet that is locally generated with no bound source address and going out on qfe2 prefers a source address hosted on vni0.
example% ifconfig qfe2 usesrc vni0
The ifconfig -a output for the qfe2 and vni0 interfaces displays as follows:
qfe2: flags=1100843<UP,BROADCAST,RUNNING,MULTICAST,ROUTER,IPv4> mtu
1500 index 4
usesrc vni0
inet 1.2.3.4 netmask ffffff00 broadcast 1.2.3.255
ether 0:3:ba:17:4b:e1 vni0: flags=20011100c1<UP,RUNNING,NOARP,NOXMIT,ROUTER,IPv4,VIRTUAL>
mtu 0 index 5
srcof qfe2
inet 3.4.5.6 netmask ffffffff
Observe, above, the usesrc and srcof keywords in the ifconfig output. These keywords also appear on the logical instances of the physical interface, even though this is a per-physical interface parameter. There is no srcof keyword in ifconfig for configuring interfaces. This information is determined automatically from the set of interfaces that have usesrc set on them.
The following command, using the none keyword, undoes the effect of the preceding ifconfig usesrc command.
example% ifconfig qfe2 usesrc none
Following this command, ifconfig -a output displays as follows:
qfe2: flags=1100843<UP,BROADCAST,RUNNING,MULTICAST,ROUTER,IPv4> mtu
1500 index 4
inet 1.2.3.4 netmask ffffff00 broadcast 1.2.3.255
ether 0:3:ba:17:4b:e1 vni0: flags=20011100c1<UP,RUNNING,NOARP,NOXMIT,ROUTER,IPv4,VIRTUAL>
mtu 0 index 5
inet 3.4.5.6 netmask ffffffff
Note the absence of the usesrc and srcof keywords in the output above.
Example 9 Configuring Source Address Selection for an IPv6 Address
The following command configures source address selection for an IPv6 address, selecting a source address hosted on vni0.
example% ifconfig qfe1 inet6 usesrc vni0
Following this command, ifconfig -a output displays as follows:
qfe1: flags=2000841<UP,RUNNING,MULTICAST,IPv6> mtu 1500 index 3
usesrc vni0
inet6 fe80::203:baff:fe17:4be0/10
ether 0:3:ba:17:4b:e0 vni0: flags=2002210041<UP,RUNNING,NOXMIT,NONUD,IPv6,VIRTUAL> mtu 0
index 5
srcof qfe1
inet6 fe80::203:baff:fe17:4444/128 vni0:1: flags=2002210040<RUNNING,NOXMIT,NONUD,IPv6,VIRTUAL> mtu 0
index 5
srcof qfe1
inet6 fec0::203:baff:fe17:4444/128 vni0:2: flags=2002210040<RUNNING,NOXMIT,NONUD,IPv6,VIRTUAL> mtu 0
index 5
srcof qfe1
inet6 2000::203:baff:fe17:4444/128
Depending on the scope of the destination of the packet going out on qfe1, the appropriately scoped source address is selected from vni0 and its aliases.
Example 10 Using Source Address Selection with Shared-IP Zones
The following is an example of how the usesrc feature can be used with the zones(7) facility in Solaris. The following commands are invoked in the global zone:
example% ifconfig hme0 usesrc vni0 example% ifconfig eri0 usesrc vni0 example% ifconfig qfe0 usesrc vni0
Following the preceding commands, the ifconfig -a output for the virtual interfaces would display as:
vni0: flags=20011100c1<UP,RUNNING,NOARP,NOXMIT,ROUTER,IPv4,VIRTUAL>
mtu 0 index 23
srcof hme0 eri0 qfe0
inet 10.0.0.1 netmask ffffffff vni0:1:
flags=20011100c1<UP,RUNNING,NOARP,NOXMIT,ROUTER,IPv4,VIRTUAL> mtu 0
index 23
zone test1
srcof hme0 eri0 qfe0
inet 10.0.0.2 netmask ffffffff vni0:2:
flags=20011100c1<UP,RUNNING,NOARP,NOXMIT,ROUTER,IPv4,VIRTUAL> mtu 0
index 23
zone test2
srcof hme0 eri0 qfe0
inet 10.0.0.3 netmask ffffffff vni0:3:
flags=20011100c1<UP,RUNNING,NOARP,NOXMIT,ROUTER,IPv4,VIRTUAL> mtu 0
index 23
zone test3
srcof hme0 eri0 qfe0
inet 10.0.0.4 netmask ffffffff
There is one virtual interface alias per zone (test1, test2, and test3). A source address from the virtual interface alias in the same zone is selected. The virtual interface aliases were created using zonecfg(8) as follows:
example% zonecfg -z test1 zonecfg:test1> add net zonecfg:test1:net> set physical=vni0 zonecfg:test1:net> set address=10.0.0.2
The test2 and test3 zone interfaces and addresses are created in the same way.
Example 11 Turning Off DHCPv6
The following example shows how to disable automatic use of DHCPv6 on all interfaces, and immediately shut down DHCPv6 on the interface named hme0. See in.ndpd(8) and ndpd.conf(5) for more information on the automatic DHCPv6 configuration mechanism.
example% echo ifdefault StatefulAddrConf false >> /etc/inet/ndpd.conf example% pkill -HUP -x in.ndpd example% ifconfig hme0 dhcp release
/etc/netmasks
/etc/default/inet_type
See attributes(7) for descriptions of the following attributes:
ATTRIBUTE TYPE | ATTRIBUTE VALUE |
Interface Stability for command-line options | Committed |
Interface Stability for command output | Uncommitted |
dhcpinfo(1), gethostbyname(3NSL), ethers(3SOCKET), getnetbyname(3SOCKET), arp(4P), ipsecah(4P), ipsecesp(4P), hosts(5), inet_type(5), ndpd.conf(5), netmasks(5), networks(5), nsswitch.conf(5), attributes(7), privileges(7), zones(7), cfgadm(8), dhcpagent(8), dladm(8), if_mpadm(8), in.mpathd(8), in.ndpd(8), in.routed(8), ipmpstat(8), ipsecconf(8), ndd(8), netstat(8), zoneadm(8), zonecfg(8)
System Administration Guide: IP Services
ifconfig sends messages that indicate if:
Do not select the names broadcast, down, private, trailers, up or other possible option names when you choose host names. If you choose any one of these names as host names, it can cause unusual problems that are extremely difficult to diagnose.
February 17, 2023 | OmniOS |