|FUSER(8)||Maintenance Commands and Procedures||FUSER(8)|
fuser - identify users of files and devices
/usr/sbin/fuser [-c | -d | -f] [-nu] [-k | -s sig] files
[ [- ] [-c | -d | -f] [-nu] [-k | -s sig] files] ...
The fuser utility displays the process IDs of the processes that are using the files specified as arguments.
Each process ID is followed by a letter code. These letter codes are interpreted as follows. If the process is using the file as
For block special devices with mounted file systems, all processes using any file on that device are listed. For all types of files (text files, executables, directories, devices, and so forth), only the processes using that file are reported.
For all types of devices, fuser also displays any known kernel consumers that have the device open. Kernel consumers are displayed in one of the following formats:
[module_name] [module_name,dev_path=path] [module_name,dev=(major,minor)] [module_name,dev=(major,minor),dev_path=path]
If more than one group of files are specified, the options may be respecified for each additional group of files. A lone dash cancels the options currently in force.
The process IDs are printed as a single line on the standard output, separated by spaces and terminated with a single new line. All other output is written on standard error.
Any user can run fuser, but only the superuser can terminate another user's process.
The following options are supported:
Example 1 Reporting on the Mount Point and Files
The following example reports on the mount point and files within the mounted file system.
example% fuser -c /export/foo
Example 2 Restricting Output when Reporting on the Mount Point and Files
The following example reports on the mount point and files within the mounted file system, but the output is restricted to processes that hold non-blocking mandatory locks.
example% fuser -cn /export/foo
Example 3 Sending SIGTERM to Processes Holding a Non-blocking Mandatory Lock
The following command sends SIGTERM to any processes that hold a non-blocking mandatory lock on file /export/foo/my_file.
example% fuser -fn -s term /export/foo/my_file
See environ(7) for descriptions of the following environment variables that affect the execution of fuser: LANG, LC_ALL LC_CTYPE, LC_MESSAGES, and NLSPATH.
See attributes(7) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
Because fuser works with a snapshot of the system image, it may miss processes that begin using a file while fuser is running. Also, processes reported as using a file may have stopped using it while fuser was running. These factors should discourage the use of the -k option.
|October 21, 2003||OmniOS|