|CRYPT_SHA256(7)||Standards, Environments, and Macros||CRYPT_SHA256(7)|
crypt_sha256 - password hashing module using SHA-256 message hash algorithm
This module is designed to make it difficult to crack passwords that use brute force attacks based on high speed SHA-256 implementations that use code inlining, unrolled loops, and table lookup.
The maximum password length for crypt_sha256 is 255 characters.
The following options can be passed to the module by means of crypt.conf(5):
The number of additional rounds is stored in the salt string returned by crypt_gensalt(3C). For example:
When crypt_gensalt(3C) is being used to generate a new salt, if the number of additional rounds configured in crypt.conf(5) is greater than that in the old salt, the value from crypt.conf(5) is used instead. This allows for migration to stronger (but more time-consuming) salts on password change.
See attributes(7) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
|May 8, 2008||OmniOS|