NET_INSTANCE_T(9S) | Data Structures for Drivers | NET_INSTANCE_T(9S) |
net_instance_t - packet event structure passed through to hooks
#include <sys/neti.h>
illumos DDI specific (illumos DDI).
The net_instance_t data structure defines a collection of instances to be called when relevant events happen within IP. The value returned by the nin_create() function is stored internally and passed back to both the nin_destroy() and nin_shutdown() functions as the second argument. The netid_t passed through to each function can be used to uniquely identify each instance of IP.
char *nin_name;
void *(*nin_create)(const netid_t);
void (*nin_destroy)(const netid_t, void *);
void (*nin_shutdown)(const netid_t, void *);
nin_name
nin_create
nin_destroy
nin_shutdown
See attributes(7) for descriptions of the following attributes:
ATTRIBUTE TYPE | ATTRIBUTE VALUE |
Interface Stability | Committed |
March 5, 2012 | OmniOS |