HOOK_NIC_EVENT(9S) | Data Structures for Drivers | HOOK_NIC_EVENT(9S) |
hook_nic_event - data structure describing events related to network interfaces
#include <sys/neti.h> #include <sys/hook.h> #include <sys/hook_event.h>
illumos DDI specific (illumos DDI).
The hook_nic_event structure contains fields that relate to an event that has occurred and belongs to a network interface. This structure is passed through to callbacks for NE_PLUMB, NE_UNPLUMB, NE_UP, NE_DOWN and NE_ADDRESS_CHANGE events.
A callback may not alter any of the fields in this structure.
net_data_t hne_family; phy_if_t pkt_private; lif_if_t hne_lif; nic_event_t hne_event; nic_event_data_t hne_data; size_t hne_datalen;
The following fields are set for each event:
hne_family
hne_nic
hne_event
NE_PLUMB
NE_UNPLUMB
NE_UP
NE_DOWN
NE_ADDRESS_CHANGE
See attributes(7) for descriptions of the following attributes:
ATTRIBUTE TYPE | ATTRIBUTE VALUE |
Interface Stability | Committed |
May 1, 2008 | OmniOS |