USB_PIPE_GET_STATE(9F) | Kernel Functions for Drivers | USB_PIPE_GET_STATE(9F) |
usb_pipe_get_state - Return USB pipe state
#include <sys/usb/usba.h> int usb_pipe_get_state(usb_pipe_handle_t pipe_handle,
usb_pipe_state_t *pipe_state, usb_flags_t usb_flags);
illumos DDI specific (illumos DDI)
pipe_handle
pipe_state
usb_flags
The usb_pipe_get_state() function retrieves the state of the pipe referred to by pipe_handle into the location pointed to by pipe_state.
Possible pipe states are:
USB_PIPE_STATE_CLOSED
USB_PIPE_STATE_ACTIVE
USB_PIPE_STATE_IDLE
USB_PIPE_STATE_ERROR
USB_PIPE_STATE_CLOSING
USB_SUCCESS
USB_INVALID_ARGS
USB_INVALID_PIPE
May be called from user, kernel or interrupt context.
usb_pipe_handle_t pipe;
usb_pipe_state_t state;
/* Recover if the pipe is in an error state. */
if ((usb_pipe_get_state(pipe, &state, 0) == USB_SUCCESS) &&
(state == USB_PIPE_STATE_ERROR)) {
cmn_err (CE_WARN, "%s%d: USB Pipe error.",
ddi_driver_name(dip), ddi_get_instance(dip));
do_recovery();
}
See attributes(7) for descriptions of the following attributes:
ATTRIBUTE TYPE | ATTRIBUTE VALUE |
Architecture | PCI-based systems |
Interface stability | Committed |
attributes(7), usb_clr_feature(9F), usb_get_cfg(9F), usb_get_status(9F), usb_pipe_close(9F), usb_pipe_ctrl_xfer(9F), usb_pipe_reset(9F), usb_pipe_xopen(9F)
September 16, 2016 | OmniOS |