USB_GET_STATUS(9F) | Kernel Functions for Drivers | USB_GET_STATUS(9F) |
usb_get_status - Get status of a USB device/endpoint/interface
#include <sys/usb/usba.h> int usb_get_status(dev_info_t *dip, usb_pipe_handle_t pipe_handle,
uint_t request_type, uint_t which, uint16_t *status,
usb_flags_t flags);
illumos DDI specific (illumos DDI)
dip
pipe_handle
request_type
USB_DEV_REQ_RCPT_DEV — Get device status.
USB_DEV_REQ_RCPT_IF — Get interface status.
USB_DEV_REQ_RCPT_EP — Get endpoint status.
which
status
flags
The usb_get_status() function returns the status of a device, interface or endpoint. All status requests use the default control pipe. Length of data returned is USB_GET_STATUS_LEN bytes. Always block and wait for resources if not available, regardless of the flags argument.
When the request_type recipient is USB_DEV_REQ_RCPT_DEV, device status is requested. Status returned includes bits for USB_DEV_SLF_PWRD_STATUS (device is currently self-powered) and USB_DEV_RWAKEUP_STATUS (device has remote wakeup enabled). A set bit indicates the corresponding status.
When the request_type is USB_DEV_REQ_RCPT_EP, endpoint status is requested. Status returned includes bits for USB_EP_HALT_STATUS (endpoint is halted). A set bit indicates the corresponding status.
When the request_type is USB_DEV_REQ_RCPT_IF, interface status is requested and USB_IF_STATUS (zero) is returned.
USB_SUCCESS
USB_INVALID_ARGS
USB_INVALID_PIPE
USB_FAILURE
May be called from user or kernel context.
uint16_t status;
if (usb_get_status(
dip, pipe_handle, USB_DEV_REQ_RCPT_DEV, 0 &status, 0) ==
USB_SUCCESS) {
if (status & USB_DEV_SLF_PWRD_STATUS) {
cmn_err (CE_WARN,
"%s%d: USB device is running on its own power.",
ddi_driver_name(dip), ddi_get_instance(dip));
}
}
See attributes(7) for descriptions of the following attributes:
ATTRIBUTE TYPE | ATTRIBUTE VALUE |
Architecture | PCI-based systems |
Interface stability | Committed |
attributes(7), usb_clr_feature(9F), usb_get_alt_if(9F), usb_pipe_get_state(9F), usb_get_cfg(9F),
January 5, 2004 | OmniOS |