NET_ZONEIDTONETID(9F) Kernel Functions for Drivers NET_ZONEIDTONETID(9F)

net_zoneidtonetid - map a zoneid_t structure identifier to a netid_t structure

#include <sys/neti.h>
netid_t net_zoneidtonetid(const zoneid_t zone);

illumos DDI specific (illumos DDI).

zone

valid zoneid_t structure that refers to a running zone.

The net_zoneidtonetid() function maps the given zoneid_t structure (used to represent a zone that is currently running) into a netid_t structure that is associated with the IP instance supporting network functions for that zone.

The net_zoneidtonetid() function returns -1 if no mapping took place. Otherwise, it returns the netid_t structure currently used by the zoneid_t structure. For zones that are using a shared IP instance, the netid_t structure for the instance owned by the global zone is returned.

The net_zoneidtonetid() function may be called from user, kernel, or interrupt context.

See attributes(7) for descriptions of the following attributes:

ATTRIBUTE TYPE ATTRIBUTE VALUE
Interface Stability Committed

attributes(7), net_netidtozonid(9F)

May 1, 2008 OmniOS