NET_NETIDTOZONID(9F) Kernel Functions for Drivers NET_NETIDTOZONID(9F)

net_netidtozonid - map a netid_t structure identifier to a zoneid_t structure

#include <sys/neti.h>
zoneid_t net_netidtozonid(const netid_t net);

illumos DDI specific (illumos DDI).

net

valid netid_t structure that refers to an existing IP instance.

The net_netidtozonid() function maps the given netid_t (used to represent an instance of IP) into the matching zoneid_t structure that is associated with it.

The net_netidtozonid() function returns -1 if no mapping took place. Otherwise, it returns the zoneid_t structure currently associated with a netid_t structure. For shared stack zones, the zoneid_t structure for the global zone is returned.

The net_netidtozonid() function may be called from user, kernel, or interrupt context.

See attributes(7) for descriptions of the following attributes:

ATTRIBUTE TYPE ATTRIBUTE VALUE
Interface Stability Committed

attributes(7), net_zoneidtonetid(9F)

May 1, 2008 OmniOS