NET_INSTANCE_REGISTER(9F) Kernel Functions for Drivers NET_INSTANCE_REGISTER(9F)

net_instance_register - register a set of instances to occur with IP instance events

#include <sys/neti.h>
int net_instance_register(net_instance_t *instances);

illumos DDI specific (illumos DDI).

instances

must be a pointer returned by net_instance_alloc(9F).

The net_instance_register() function attempts to record the set of functions passed by instances that are to be called when an event related to IP instance maintenance occurs.

If the net_instance_register() function succeeds, DDI_SUCCESS is returned. Otherwise, DDI_FAILURE is returned to indicate failure due to the name in the instance already being present.

The net_instance_register() function may be called from user or kernel context.

See attributes(7) for descriptions of the following attributes:

ATTRIBUTE TYPE ATTRIBUTE VALUE
Interface Stability Committed

attributes(7), net_instance_alloc(9F), net_instance_unregister(9F), net_instance_t(9S)

May 1, 2008 OmniOS