NET_GETPMTUENABLED(9F) Kernel Functions for Drivers NET_GETPMTUENABLED(9F)

net_getpmtuenabled - determine if path MTU discovery is enabled for a network protocol

#include <sys/neti.h>
int net_getpmtuenabled(const net_data_t net);

illumos DDI specific (illumos DDI).

net

value returned from a successful call to net_protocol_lookup(9F).

The net_getpmtuenabled() function returns a value to indicate whether or not path MTU (PMTU) discovery is enabled for this network protocol.

The net_getpmtuenabled() function returns:

-1

The network protocol does not support this function.

0

PATH MTU discovery is disabled.

1

PATH MTU discovery is enabled.

The net_getpmtuenabled() function may be called from user, kernel, or interrupt context.

See attributes(7) for descriptions of the following attributes:

ATTRIBUTE TYPE ATTRIBUTE VALUE
Interface Stability Committed

net_getmtu(9F), net_protocol_lookup(9F)

May 1, 2008 OmniOS