NET_GETMTU(9F) Kernel Functions for Drivers NET_GETMTU(9F)

net_getmtu - determine the MTU of a given network interface

#include <sys/neti.h>
int net_getmtu(const net_data_t net, const phy_if_t ifp);

illumos DDI specific (illumos DDI).

net

value returned from a successful call to net_protocol_lookup(9F).

ifp

value returned from a successful call to net_phylookup(9F) or net_phygetnext(9F).

The net_getmtu() function receives information about the current MTU of a network interface. The value returned from this function call should not be cached as the MTU of a network interface since it is not guaranteed to be constant.

The net_getmtu() function returns -1 if the network protocol does not support this feature and otherwise returns the current MTU of the network interface.

The net_getmtu() function may be called from user, kernel, or interrupt context.

See attributes(7) for descriptions of the following attributes:

ATTRIBUTE TYPE ATTRIBUTE VALUE
Interface Stability Committed

net_phygetnext(9F), net_phylookup(9F), net_protocol_lookup(9F)

May 1, 2008 OmniOS