|MKFILE(8)||Maintenance Commands and Procedures||MKFILE(8)|
mkfile [-nv] size [g | k | b | m] filename...
mkfile creates one or more files that are suitable for use as NFS-mounted swap areas, or as local swap areas. When a root user executes mkfile(), the sticky bit is set and the file is padded with zeros by default. When non-root users execute mkfile(), they must manually set the sticky bit using chmod(1). The default size is in bytes, but it can be flagged as gigabytes, kilobytes, blocks, or megabytes, with the g, k, b, or m suffixes, respectively.
The following exit values are returned:
See largefile(7) for the description of the behavior of mkfile when encountering files greater than or equal to 2 Gbyte ( 2^31 bytes).
See attributes(7) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
|February 20, 2008||OmniOS|