|KPROPD(8)||Maintenance Commands and Procedures||KPROPD(8)|
/usr/lib/krb5/kpropd [-d] [-f temp_dbfile] [-F dbfile] [-p kdb_util] [-P port_number] [-r realm] [-s srv_tabfile] [-S] [-a acl_file]
The kpropd command runs on the slave KDC server. It listens for update requests made by kprop(8) from the master KDC and periodically requests incremental updates from the master KDC.
When the slave receives a kprop request from the master, kpropd copies principal data to a temporary text file. Next, kpropd invokes kdb5_util(8) (unless a different database utility is selected) to load the text file in database format.
When the slave periodically requests incremental updates, kpropd update its principal.ulog file with any updates from the master. kproplog(8) can be used to view a summary of the update entry log on the slave KDC.
kpropd is not configured for incremental database propagation by default. These settings can be changed in the kdc.conf(5) file:
sunw_dbprop_enable = [true | false]
sunw_dbprop_slave_poll = N[s, m, h]
The kiprop/<hostname>@<REALM> principal must exist in the slave's keytab file to enable the master to authenticate incremental propagation requests from the slave. In this syntax, <hostname> is the slave KDC's host name and <REALM> is the realm in which the slave KDC resides.
The following options are supported:
See attributes(7) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
The kprop service is managed by the service management facility, smf(7), under the service identifier:
Administrative actions on this service, such as enabling, disabling, or requesting restart, can be performed using svcadm(8). Responsibility for initiating and restarting this service is delegated to inetd(8). Use inetadm(8) to make configuration changes and to view configuration information for this service. The service's status can be queried using the svcs(1) command.
|July 11, 2005||OmniOS|