|PAM_UNIX_ACCOUNT(7)||Standards, Environments, and Macros||PAM_UNIX_ACCOUNT(7)|
pam_unix_account - PAM account management module for UNIX
The pam_unix_account module implements pam_sm_acct_mgmt(3PAM), which provides functionality to the PAM account management stack. The module provides functions to validate that the user's account is not locked or expired and that the user's password does not need to be changed. The module retrieves account information from the configured databases in nsswitch.conf(5).
The following options can be passed to the module:
The following values are returned:
See attributes(7) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
|MT Level||MT-Safe with exceptions|
The interfaces in libpam(3LIB) are MT-Safe only if each thread within the multi-threaded application uses its own PAM handle.
Attempts to validate locked accounts are logged via syslog(3C) to the LOG_AUTH facility with a LOG_NOTICE severity.
|August 19, 2023||OmniOS|