|DAT.CONF(5)||File Formats and Configurations||DAT.CONF(5)|
The DAT static registry, /etc/dat/dat.conf is a system-wide data resource maintained by the system administrative command datadm(8).
/etc/dat/dat.conf contains a list of interface adapters supported by uDAPL service providers. An interface adapter on Infiniband (IB) corresponds to an IPoIB device instance, for example, ibd0. An IPoIB device name represents an IP interface plumbed by ifconfig(8) on an IB partition/Host Channel Adapter port combination.
Each entry in the DAT static registry is a single line that contains eight fields. Fields are separated by a SPACE. Lines that begin with a pound sign (#) are considered comments. All characters that follow the # are ignored. Enclose Solaris specific strings (Solaris_specific_string) and service provider's instance data (service _provider_instance_data) in quotes.
The following shows the order of the fields in a dat.conf entry:
"interface_adapter_name" "API_version" "threadsafe | nonthreadsafe" \ "default | nondefault" "service_provider_library_pathname" \ "service_provider_version" "service _provider_instance_data"\ "Solaris_specific_string"
The fields are defined as follows:
threadsafe | nonthreadsafe
default | nondefault
The following dat.conf file shows a uDAPL 1.2 service provider for tavor, udapl_tavor.so.1 supporting two interfaces, ibd0 and ibd1:
# # dat.conf for uDAPL 1.2 # ibd0 u1.2 nonthreadsafe default udapl_tavor.so.1 SUNW.1.0 "" "driver_name=tavor" ibd1 u1.2 nonthreadsafe default udapl_tavor.so.1 SUNW.1.0 "" "driver_name=tavor"
See attributes(7) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
An empty dat.conf is created during the package SUNWudaplr installation if no file is present beforehand. Entries in the file are added or removed by running datadm(8).
The content of the platform specific string does not constitute an API. It is generated by datadm(8) and might have a different content or interpretation in a future release.
|June 18, 2004||OmniOS|