in.timed - UDP or TCP time protocol service daemon
FMRI stands for Fault Management Resource Identifier. It is used
to identify resources managed by the Fault Manager. See fmd(1M) and
The in.timed service provides the server-side of the time
protocol. The time server sends to requestors the time in seconds since
midnight, January 1, 1900. The time protocol is available on both TCP and
UDP transports through port 37.
The in.timed service is an inetd(1M) smf(5)
delegated service. The in.timed detects which transport is requested
by examining the socket it is passed by the inetd daemon.
Once a connection is established, the in.timed
sends the time as a 32-bit binary number and closes the connection. Any
received data is ignored.
The in.timed listens for UDP datagrams. When a
datagram is received, the server generates a UDP datagram containing the time
as a 32-bit binary number and sends it to the client. Any received data is
See attributes(5) for descriptions of the following