IPADM(8) Maintenance Commands and Procedures IPADM(8)

ipadmconfigure IP and IPMP interfaces, addresses and protocols

ipadm help

ipadm create-if [-t] interface

ipadm create-ip [-t] interface

ipadm delete-if interface

ipadm delete-ip interface


ipadm create-ipmp [-t] [-i interface[,interface]...] ipmp-interface

ipadm delete-ipmp ipmp-interface

ipadm add-ipmp [-t] -i interface[,interface]... ipmp-interface

ipadm remove-ipmp [-t] -i interface[,interface]... ipmp-interface


ipadm disable-if -t interface

ipadm enable-if -t interface

ipadm show-if [[-p] -o field[,field]...] [interface]


ipadm set-ifprop [-t] -p prop=value[,value]... -m protocol interface

ipadm reset-ifprop [-t] -p prop -m protocol interface

ipadm show-ifprop [[-c] -o field[,value]...] [-p prop[,prop]...] [-m protocol] [interface]


ipadm create-addr [-t] -T static [-d] -a [local|remote=]addr[/prefixlen]... addrobj

ipadm create-addr [-t] -T dhcp [-1] [-h hostname] [-w {seconds|forever}] addrobj

ipadm create-addr [-t] -T addrconf [-i interface-id] [-p {stateful|stateless}={yes|no}]... addrobj

ipadm delete-addr [-r] addrobj

ipadm show-addr [[-p] -o field[,field]...] [addrobj | interface/]

ipadm refresh-addr [-i] addrobj

ipadm down-addr [-t] addrobj

ipadm up-addr [-t] addrobj

ipadm disable-addr [-t] addrobj

ipadm enable-addr [-t] addrobj


ipadm set-addrprop [-t] -p prop=value[,value]... addrobj

ipadm reset-addrprop [-t] -p prop addrobj

ipadm show-addrprop [[-c] -o field[,field]...] [-p prop[,prop]...] [addrobj | interface/]


ipadm set-prop [-t] -p prop[+|-]=value[,value]... protocol

ipadm reset-prop [-t] -p prop protocol

ipadm show-prop [[-c] -o field[,field]...] [-p prop[,prop]...] [protocol]

The ipadm command is a stable replacement for the ifconfig(8) and ndd(8) commands. It is used to create IP interfaces and to configure IP addresses on those interfaces. It is also used to get, set or reset properties on interfaces, addresses and protocols.

For subcommands that take an addrobj, the addrobj specifies a unique address on the system, and must be unique itself. It is made up of two parts, delimited by a ‘/’. The first part is the name of the interface and the second part is an arbitrary string up to 32 alphanumeric characters long, where the first character must be alphabetic (e.g. a-z,A-Z). For example, "lo0/v4" is a loopback interface addrobj name, which could also be called "lo0/ipv4loopback". Consumers should note that this length limit may be lifted in the future.

For subcommands that take a , this can be one of the following values: ip, ipv4, ipv6, icmp, tcp, sctp or udp.

When invoked with no arguments, ipadm shows the current address properties, in the same way as ipadm show-addr.

The following subcommands are supported:

ipadm help
Display brief command usage.

ipadm create-if [-t] interface
 
ipadm create-ip [-t] interface
Create an IP interface that will handle both IPv4 and IPv6 packets. The interface will be enabled as part of the creation process. The IPv4 interface will have the address 0.0.0.0. The IPv6 interface will have the address ::. The subcommands create-if and create-ip are functionally equivalent aliases of each other.
,--temporary
Temporary, not persistent across reboots.

ipadm delete-if interface
 
ipadm delete-ip interface
Permanently delete the specified IP interface. The subcommands delete-if and delete-ip are functionally equivalent aliases of each other.

ipadm create-ipmp [-t] [-i interface[,interface]...] ipmp-interface
Create an IPMP interface that will handle both IPv4 and IPv6 packets. The interface will be enabled as part of the creation process. The IPv4 interface will have the address 0.0.0.0. The IPv6 interface will have the address ::.
,--interface
Interface(s) to be added to the new IPMP interface.
,--temporary
Temporary, not persistent across reboots.

ipadm delete-ipmp ipmp-interface
Permanently delete the IPMP interface.

ipadm add-ipmp [-t] -i interface[,interface]... ipmp-interface
Add the IP interface(s) to the IPMP interface.
,--interface
Interface(s) to be added to the IPMP interface.
,--temporary
Temporary, not persistent across reboots.

ipadm remove-ipmp [-t] -i interface[,interface]... ipmp-interface
Remove the IP interface(s) from the IPMP interface.
,--interface
Interface(s) to be removed from the IPMP interface.
,--temporary
Temporary, not persistent across reboots.

ipadm disable-if -t interface
Disable the specified IP interface.
,--temporary
Temporary, not persistent across reboots.

ipadm enable-if -t interface
Enable the specified IP interface.
,--temporary
Temporary, not persistent across reboots.

ipadm show-if [[-p] -o field[,field]...] [interface]
Show the current IP interface configuration.
,--output
Select which fields will be shown. The field value can be one of the following names:
Display all fields.
The name of the interface.
The state can be one of the following values:
resources for the interface have been allocated
the interface is offline
the interface's datalink is down
the interface is down
the interface is disabled
A set of single character flags indicating the following:
broadcast (mutually exclusive with ‘p’)
multicast
point-to-point (mutually exclusive with ‘b’)
virtual interface
IPMP
IPMP standby
IPMP inactive
VRRP
VRRP accept mode
IPv4
IPv6
A set of single character flags showing what configuration will be used the next time the interface is enabled:
IPMP standby
IPv4
IPv6
,--parsable
Print the output in a parsable format.

ipadm set-ifprop [-t] -p prop=value[,value]... -m protocol interface
Set a property's value(s) on the specified IP interface.
,--module
Specify which protocol the setting applies to.
,--prop
Specify the property name and value(s). The property name can be one of the following:
Address resolution protocol (on/off).
Exchange of routing data (on/off).
IP Forwarding (on/off)
Set the routing metric to the numeric value. The value is treated as extra hops to the destination.
Set the maximum transmission unit to the numeric value.
Neighbor unreachability detection (on/off)
Indicates which interface to use for source address selection. A value none may also be used.
,--temporary
Temporary, not persistent across reboots.

ipadm reset-ifprop [-t] -p prop -m protocol interface
Reset the specified IP interface's property value to the default.
,--module
Specify which protocol the setting applies to.
,--prop
Specify the property name. See the ipadm set-ifprop subcommand for the list of property names.
,--temporary
Temporary, not persistent across reboots.

ipadm show-ifprop [[-c] -o field[,value]...] [-p prop[,prop]...] [-m protocol] [interface]
Display the property values for one or all of the IP interfaces.
,--parsable
Print the output in a parsable format.
,--module
Specify which protocol to display.
,--output
Select which fields will be shown. The field value can be one of the following names:
Display all fields.
The name of the interface.
The name of the property.
The name of the protocol.
If the property is readable ("r") and/or writable ("w").
The value of the property.
The persistent value of the property.
The default value of the property.
The possible values for the property.
,--prop
Specify which properties to display. See the ipadm set-ifprop subcommand for the list of property names.

ipadm create-addr [-t] -T static [-d] -a [local|remote=]addr[/prefixlen]... addrobj
Create an address on the specified IP interface using static configuration. The address will be enabled but can disabled using the ipadm disable-addr subcommand. Note that addrconf address configured on the interface is required to configure static IPv6 address on the same interface. This takes the following options:
,--address
Specify the address. The local or remote prefix can be used for a point-to-point interface. In this case, both addresses must be given. Otherwise, the equal sign ("=") should be omitted and the address should be provided by itself without second address.
,--down
The address is down.
,--temporary
Temporary, not persistent across reboots.

ipadm create-addr [-t] -T dhcp [-1] [-h hostname] [-w {seconds|forever}] addrobj
Create an address on the specified IP interface using DHCP. This takes the following options:
,--primary
Specify that the interface is primary. One effect will be that nodename(5) will serve as -h,--reqhost if that switch is not otherwise specified.
,--reqhost
Specify the host name to send to the DHCP server in order to request an association of a Fully Qualified Domain Name to the interface. An FQDN is determined from hostname if it is "rooted" (ending in a '.'), or if it consists of at least three DNS labels, or by appending to hostname the DNS domain name value configured in /etc/default/dhcpagent for dhcpagent(8). Note that the DHCP server implementation ultimately determines whether and how the client-sent FQDN is used.
,--temporary
Temporary, not persistent across reboots.
,--wait
Specify the time, in seconds, that the command should wait to obtain an address; or specify forever to wait without interruption. The default value is 120.

ipadm create-addr [-t] -T addrconf [-i interface-id] [-p {stateful|stateless}={yes|no}]... addrobj
Create an auto-configured address on the specified IP interface. This takes the following options:
,--interface-id
Specify the interface ID to be used.
,--prop
Specify which method of auto-configuration should be used.
,--temporary
Temporary, not persistent across reboots.

ipadm delete-addr [-r] addrobj
Delete the given address.
,--release
Indicate that the DHCP-assigned address should be released.

ipadm show-addr [[-p] -o field[,field]...] [addrobj | interface/]
Show the current address properties; optionally limited to those for the provided addrobj or for all address objects on the specified interface.
,--output
Select which fields will be shown. The field value can be one of the following names:
Display all fields.
The name of the address.
The type of the address (//).
The state of the address. It can be one of the following values:
see the ipadm disable-addr subcommand
see the ipadm down-addr subcommand
the address is duplicate
the interface for this address has failed
the address is up
duplicate address detection in progress
A set of single character flags indicating the following:
up
unnumbered (matches another local address)
private, not advertised to routing
temporary IPv6 address
deprecated (not used for outgoing packets)
A set of single character flags showing the configuration which will be used when the address is enabled.
up
private, not advertised to routing
deprecated (not used for outgoing packets)
The address.
,--parsable
Print the output in a parsable format.

ipadm refresh-addr [-i] addrobj
Extend the lease for addresses. It also restarts duplicate address detection for static addresses.
,--inform
Obtain network configuration from DHCP without taking a lease on the address.

ipadm down-addr [-t] addrobj
Down the address. This will stop packets from being sent or received.
,--temporary
Temporary, not persistent across reboots.

ipadm up-addr [-t] addrobj
Up the address. This will enable packets to be sent and received.
,--temporary
Temporary, not persistent across reboots.

ipadm disable-addr [-t] addrobj
Disable the address.
,--temporary
Temporary, not persistent across reboots.

ipadm enable-addr [-t] addrobj
Enable the address.
,--temporary
Temporary, not persistent across reboots.

ipadm set-addrprop [-t] -p prop=value[,value]... addrobj
Set a property's value(s) on the specified addrobj.
,--prop
Specify the property name and value(s). The property name can be one of the following:
The broadcast address (read-only).
The address should not be used to send packets but can still receive packets (on/off).
The number of bits in the IPv4 netmask or IPv6 prefix.
The DHCP primary interface flag (read-only).
The address is not advertised to routing (on/off).
The host name to send to the DHCP server in order to request an association of the FQDN to the interface. For a primary DHCP interface, nodename(5) is sent if this property is not defined. See the ipadm create-addr -T dhcp subcommand for the explanation of how an FQDN is determined.
Packets can be transmitted (on/off).
The zone the addrobj is in (temporary-only — use zonecfg(8) to make persistent).
,--temporary
Temporary, not persistent across reboots.

ipadm reset-addrprop [-t] -p prop addrobj
Reset the addrobj's property value to the default.
,--prop
Specify the property name. See the ipadm set-addrprop subcommand for the list of property names.
,--temporary
Temporary, not persistent across reboots.

ipadm show-addrprop [[-c] -o field[,field]...] [-p prop[,prop]...] [addrobj | interface/]
Display property values; optionally limited to those for the provided addrobj or for all address objects on the specified interface.
,--parsable
Print the output in a parsable format.
,--output
Select which fields will be shown. The field value can be one of the following names:
Display all fields.
The name of the addrobj.
The name of the property.
If the property is readable ("r") and/or writable ("w").
The value of the property.
The persistent value of the property.
The default value of the property.
The possible values for the property.
,--prop
Specify which properties to display. See the ipadm set-addrprop subcommand for the list of property names.

ipadm set-prop [-t] -p prop[+|-]=value[,value]... protocol
Set a property's value(s) on the protocol.
,--prop
Specify the property name and value(s). The optional |- syntax can be used to add/remove values from the current list of values on the property. The property name can be one of the following:
The default congestion-control algorithm to be used for new connections (TCP).
Explicit congestion control (never/passive/active) (TCP).
Additional privileged ports (SCTP/TCP/UDP).
Packet forwarding (on/off).
The IPv6 hoplimit.
IP packet handling on multi-homed systems (weak/strong/src-priority) (IPv4/IPv6). weak and strong correspond to the model definitions defined in RFC 1122. src-priority is a hybrid mode where outbound packets are sent from the interface with the packet's source address if possible.
Largest ephemeral port (SCTP/TCP/UDP).
Maximum receive or send buffer size (ICMP/SCTP/TCP/UDP). This also sets the upper limit for the recv_buf and send_buf properties.
Default receive buffer size (ICMP/SCTP/TCP/UDP). The maximum value for this property is controlled by the max_buf property.
Selective acknowledgement (active/passive/never) (TCP).
Default send buffer size (ICMP/SCTP/TCP/UDP). The maximum value for this property is controlled by the max_buf property.
Smallest ephemeral port (SCTP/TCP/UDP).
Smallest non-privileged port (SCTP/TCP/UDP).
The IPv4 time-to-live.
,--temporary
Temporary, not persistent across reboots.

ipadm reset-prop [-t] -p prop protocol
Reset a protocol's property value to the default.
,--prop
Specify the property name. See the ipadm set-prop subcommand for the list of property names.
,--temporary
Temporary, not persistent across reboots.

ipadm show-prop [[-c] -o field[,field]...] [-p prop[,prop]...] [protocol]
Display the property values for one or all of the protocols.
,--parsable
Print the output in a parsable format.
,--output
Select which fields will be shown. The field value can be one of the following names:
Display all fields.
The name of the protocol.
The name of the property.
If the property is readable ("r") and/or writable ("w").
The value of the property.
The persistent value of the property.
The default value of the property.
The possible values for the property.
,--prop
Specify which properties to display. See the ipadm set-prop subcommand for the list of property names.

nodename(5), nsswitch.conf(5), dhcp(7), arp(8), cfgadm(8), dhcpagent(8), dladm(8), if_mpadm(8), ifconfig(8), ndd(8), zonecfg(8)

January 14, 2024 OmniOS