USB_HANDLE_REMOTE_WAKEUP(9F) Kernel Functions for Drivers USB_HANDLE_REMOTE_WAKEUP(9F)

usb_handle_remote_wakeup - Enable or disable remote wakeup on USB devices

#include <sys/usb/usba.h>
int usb_handle_remote_wakeup(dev_info_t *dip, int cmd);

illumos DDI specific (illumos DDI)

dip

Pointer to the device's dev_info structure.

cmd

Command. Either USB_REMOTE_WAKEUP_ENABLE or USB_REMOTE_WAKEUP_DISABLE.

The usb_handle_remote_wakeup() function enables or disables remote wakeup on a USB device. This call can block.

USB_SUCCESS

Remote wakeup is successfully enabled or disabled.

USB_FAILURE

Remote wakeup is not supported by the device. An internal error occurred.

May be called from user or kernel context.



uint_t *pwrstates;
/* Hook into device's power management. Enable remote wakeup. */
if (usb_create_pm_components(dip, pwrstates) == USB_SUCCESS) {
usb_handle_remote_wakeup(dip, USB_REMOTE_WAKEUP_ENABLE);
}

See attributes(7) for descriptions of the following attributes:

ATTRIBUTE TYPE ATTRIBUTE VALUE
Architecture PCI-based systems
Interface stability Committed

attributes(7), pm_busy_component(9F), pm_idle_component(9F), pm_lower_power(9F), pm_raise_power(9F), usb_clr_feature(9F), usb_create_pm_components(9F), usb_get_cfg(9F), usb_get_dev_data(9F), usb_register_hotplug_cbs(9F), usb_cfg_descr(9S)

February 5, 2004 OmniOS