SCSI_HBA_PKT_COMP(9F) Kernel Functions for Drivers SCSI_HBA_PKT_COMP(9F)

scsi_hba_pkt_comp - scsi_pkt completion routine

#include <sys/scsi/scsi.h>
void scsi_hba_pkt_comp(struct scsi_pkt *pkt);

pkt

Pointer to a scsi_pkt(9S) structure.

illumos DDI specific (illumos DDI).

After filling in scsi_pkt(9S) fields with packet completion information, an HBA driver should call the scsi_hba_pkt_comp() function. This function is the recommended way for an HBA driver to signal completion of a scsi_pkt structure. Use is mandatory for HBA drivers that use tran_setup_pkt(9E).

Calling the scsi_hba_pkt_comp() function allows SCSA to observe, and possibly react to, the completion of a scsi_pkt request.

A call to the scsi_hba_pkt_comp() function will always result in a call to the pkt_comp() callback function defined in scsi_pkt(9S). This pkt_comp() callback may, however, occur after return from scsi_hba_pkt_comp(), and may occur from a different thread executing on a different CPU.

The scsi_hba_pkt_comp() function can be called from user, interrupt, or kernel context.

See attributes(7) for descriptions of the following attributes:

ATTRIBUTE TYPE ATTRIBUTE VALUE
Interface Stability Committed

attributes(7), tran_setup_pkt(9E), scsi_pkt(9S)

HBA driver calls scsi_hba_pkt_comp() instead of calling scsi_pkt(9S) pkt_comp directly.

January 29, 2009 OmniOS