SCSI_HBA_LOOKUP_CAPSTR(9F) | Kernel Functions for Drivers | SCSI_HBA_LOOKUP_CAPSTR(9F) |
scsi_hba_lookup_capstr - return index matching capability string
#include <sys/scsi/scsi.h> int scsi_hba_lookup_capstr(char *capstr);
illumos architecture specific (illumos DDI).
capstr
The scsi_hba_lookup_capstr() function attempts to match capstr against a known set of capability strings. If found, the defined index for the matched capability is returned.
The following indices are defined for the capability strings listed below.
SCSI_CAP_DMA_MAX
SCSI_CAP_MSG_OUT
SCSI_CAP_DISCONNECT
SCSI_CAP_SYNCHRONOUS
SCSI_CAP_WIDE_XFER
SCSI_CAP_PARITY
SCSI_CAP_INITIATOR_ID
SCSI_CAP_UNTAGGED_QING
SCSI_CAP_TAGGED_QING
SCSI_CAP_ARQ
SCSI_CAP_LINKED_CMDS
SCSI_CAP_SECTOR_SIZE
SCSI_CAP_TOTAL_SECTORS
SCSI_CAP_GEOMETRY
SCSI_CAP_RESET_NOTIFICATION
SCSI_CAP_QFULL_RETRIES
SCSI_CAP_QFULL_RETRY_INTERVAL
SCSI_CAP_LUN_RESET
SCSI_CAP_CDB_LEN
The scsi_hba_lookup_capstr() function returns a non-negative index value that corresponds to the capability string. If the string does not match a known capability, -1 is returned.
The scsi_hba_lookup_capstr() function can be called from user, interrupt, or kernel context.
See attributes(7) for descriptions of the following attributes:
ATTRIBUTE TYPE | ATTRIBUTE VALUE |
Interface Stability | Committed |
tran_getcap(9E), tran_setcap(9E), scsi_ifgetcap(9F), scsi_ifsetcap(9F), scsi_reset_notify(9F)
Writing Device Drivers
May 13, 2006 | OmniOS |