PCI_CONFIG_SETUP(9F) Kernel Functions for Drivers PCI_CONFIG_SETUP(9F)

pci_config_setup, pci_config_teardown - setup or tear down the resources for enabling accesses to the PCI Local Bus Configuration space

#include <sys/ddi.h>
#include <sys/sunddi.h>
int pci_config_setup(dev_info_t *dip, ddi_acc_handle_t *handle);

void pci_config_teardown(ddi_acc_handle_t *handle);

illumos DDI specific (illumos DDI).

dip

Pointer to the device's dev_info structure.

handle

Pointer to a data access handle.

pci_config_setup() sets up the necessary resources for enabling subsequent data accesses to the PCI Local Bus Configuration space. pci_config_teardown() reclaims and removes those resources represented by the data access handle returned from pci_config_setup().

pci_config_setup() returns:

DDI_SUCCESS

Successfully setup the resources.

DDI_FAILURE

Unable to allocate resources for setup.

pci_config_setup() must be called from user or kernel context. pci_config_teardown() can be called from any context.

These functions are specific to PCI bus device drivers. For drivers using these functions, a single source to support devices with multiple bus versions may not be easy to maintain.

See attributes(7) for descriptions of the following attributes:

ATTRIBUTE TYPE ATTRIBUTE VALUE
Architecture PCI Local Bus

attributes(7)

IEEE 1275 PCI Bus Binding

March 27, 2016 OmniOS