NVLIST_LOOKUP_NVPAIR(9F) | Kernel Functions for Drivers | NVLIST_LOOKUP_NVPAIR(9F) |
nvlist_lookup_nvpair, nvlist_exists - lookup named pairs
#include <libnvpair.h> int nvlist_lookup_nvpair(nvlist_t *nvl, const char *name,
nvpair_t **nvp);
boolean_t nvlist_exists(nvlist_t *nvl, const char *name);
The nvlist_lookup_nvpair() function returns the nvpair with the matching name, regardless of type. It is valid only for lists allocated with NV_UNIQUE_NAME. See nvlist_alloc(9F).
The nvlist_exists() function returns success if any nvpair exists with the given name. It is valid for all types of lists.
The nvlist_lookup_nvpair() function returns 0 on success and an error value on failure.
The nvlist_exists() function returns B_TRUE if an nvpair with the given name exists and B_FALSE otherwise.
The nvlist_lookup_nvpair() function will fail if:
EINVAL
ENOENT
ENOTSUP
See attributes(7) for descriptions of the following attributes:
ATTRIBUTE TYPE | ATTRIBUTE VALUE |
Interface Stability | Committed |
nvlist_lookup_nvpair(3NVPAIR), attributes(7), nvlist_alloc(9F)
October 24, 2007 | OmniOS |