NET_ROUTETO(9F) | Kernel Functions for Drivers | NET_ROUTETO(9F) |
net_routeto - indicate which network interface packets are sent
#include <sys/neti.h> phy_if_t net_routeto(const net_data_t *net, struct sockaddr *address,
struct sockaddr *nexthop);
illumos DDI specific (illumos DDI).
net
address
nexthop
The net_routeto() function indicates which network interface packets destined for a particular address would be sent out of, according to the systems network routing tables. If next is supplied as a non-NULL pointer, the IP address of the nexthop router to be used is returned in it.
The net_routeto() function returns:
-1
0
>0
The net_routeto() function may be called from user, kernel, or interrupt context.
See attributes(7) for descriptions of the following attributes:
ATTRIBUTE TYPE | ATTRIBUTE VALUE |
Interface Stability | Committed |
attributes(7), net_phygetnext(9F), net_phylookup(9F), net_protocol_lookup(9F)
May 1, 2008 | OmniOS |