NET_PROTOCOL_RELEASE(9F) Kernel Functions for Drivers NET_PROTOCOL_RELEASE(9F)

net_protocol_release - indicate that a reference to a network protocol is no longer required

#include <sys/neti.h>
int net_protocol_release(net_handle_t info);

illumos DDI specific (illumos DDI).

info

value returned from a successful call to net_protocol_lookup(9F).

The net_protocol_release() function indicates to the network information framework that the caller is no longer interested in any knowledge about the network protocol to which the parameter being passed through applies.

The net_protocol_release() function returns:

-1

The value passed in is unknown to this framework.

0

Successful completion.

1

Unsuccessful because this function has been called too many times.

The net_protocol_release() function may be called from user, kernel, or interrupt context.

See attributes(7) for descriptions of the following attributes:

ATTRIBUTE TYPE ATTRIBUTE VALUE
Interface Stability Committed

attributes(7), net_protocol_lookup(9F), net_protocol_walk(9F)

March 5, 2012 OmniOS