NET_GETIFNAME(9F) Kernel Functions for Drivers NET_GETIFNAME(9F)

net_getifname - determine the name given to a network interface

#include <sys/neti.h>
int net_getifname(const net_data_t net, const phy_if_t ifp,

char *buffer, size_t buflen);

illumos DDI specific (illumos DDI).

net

value returned from a successful call to net_protocol_lookup(9F).

ifp

value returned from a successful call to net_phylookup(9F) or net_phygetnext(9F).

buffer

pointer to the buffer in which to write the interface name.

buflen

size of the buffer in which to store the interface name.

The net_getifname() function copies the name of the network interface into the buffer provided. The name will always be null-terminated. If the buffer is too small to fit both the interface name and the null-terminated name, the name in the buffer is truncated to fit. See net_phygetnext(9F) for an example on how to use this function.

The net_getifname() function returns:

-1

The network protocol does not support this function.

0

Successful completion.

1

Unsuccessful.

The net_getifname() function may be called from user, kernel, or interrupt context.

See attributes(7) for descriptions of the following attributes:

ATTRIBUTE TYPE ATTRIBUTE VALUE
Interface Stability Committed

net_phygetnext(9F), net_phylookup(9F), net_protocol_lookup(9F)

May 1, 2008 OmniOS