HOOK_ALLOC(9F) Kernel Functions for Drivers HOOK_ALLOC(9F)

hook_alloc - allocate a hook_t data structure

#include <sys/hook.h>
hook_t *hook_alloc(const int version);

illumos DDI specific (illumos DDI).

version

must always be the symbol HOOK_VERSION.

The hook_alloc() function allocates a hook_t structure, returning a pointer for the caller to use.

Upon success, hook_alloc() returns a pointer to the allocated hook_t structure. On failure, hook_alloc() returns a NULL pointer.

The hook_alloc() function may be called from user or kernel context.

See attributes(7) for descriptions of the following attributes:

ATTRIBUTE TYPE ATTRIBUTE VALUE
Interface Stability Committed

hook_free(9F), hook_t(9S)

May 1, 2008 OmniOS