DDI_REGS_MAP_FREE(9F) Kernel Functions for Drivers DDI_REGS_MAP_FREE(9F)

ddi_regs_map_free - free a previously mapped register address space

#include <sys/ddi.h>
#include <sys/sunddi.h>
void ddi_regs_map_free(ddi_acc_handle_t *handle);

illumos DDI specific (illumos DDI).

handle

Pointer to a data access handle previously allocated by a call to a setup routine such as ddi_regs_map_setup(9F).

ddi_regs_map_free() frees the mapping represented by the data access handle handle. This function is provided for drivers preparing to detach themselves from the system, allowing them to release allocated system resources represented in the handle.

ddi_regs_map_free() must be called from user or kernel context.

See attributes(7) for descriptions of the following attributes:

ATTRIBUTE TYPE ATTRIBUTE VALUE
Architecture PCI Local Bus, SBus, ISA

attributes(7), ddi_regs_map_setup(9F)

Writing Device Drivers

November 18, 2004 OmniOS