DDI_IO_PUT8(9F) | Kernel Functions for Drivers | DDI_IO_PUT8(9F) |
ddi_io_put8, ddi_io_put16, ddi_io_put32 - write data to the mapped device register in I/O space
#include <sys/ddi.h> #include <sys/sunddi.h> void ddi_io_put8(ddi_acc_handle_t handle, uint8_t *dev_addr,
uint8_t value);
void ddi_io_put16(ddi_acc_handle_t handle, uint16_t *dev_addr,
uint16_t value);
void ddi_io_put32(ddi_acc_handle_t handle, uint32_t *dev_addr,
uint32_t value);
illumos DDI specific (illumos DDI). The ddi_io_put8(), ddi_io_put16(), ddi_io_put32(), ddi_io_putb(), ddi_io_putl(), and ddi_io_putw() functions are obsolete. The ddi_put8(9F) function replaces ddi_io_put8(). The ddi_put16(9F) function replaces ddi_io_put16(). The ddi_put32(9F) function replaces ddi_io_put32().
handle
dev_addr
value
These routines generate a write of various sizes to the device address, dev_addr, in I/O space. The ddi_io_put8(), ddi_io_put16(), and ddi_io_put32() functions write 8 bits, 16 bits, and 32 bits of data, respectively, to the device address, dev_addr.
Each individual datum will automatically be translated to maintain a consistent view between the host and the device based on the encoded information in the data access handle. The translation may involve byte-swapping if the host and the device have incompatible endian characteristics.
These functions can be called from user, kernel, or interrupt context.
See attributes(7) for descriptions of the following attributes:
ATTRIBUTE TYPE | ATTRIBUTE VALUE |
Interface Stability | Obsolete |
isa(5), ddi_io_get8(9F), ddi_io_rep_get8(9F), ddi_io_rep_put8(9F), ddi_put16(9F), ddi_put32(9F), ddi_put8(9F), ddi_regs_map_setup(9F), ddi_device_acc_attr(9S)
November 1, 2005 | OmniOS |