DDI_IO_GET8(9F) Kernel Functions for Drivers DDI_IO_GET8(9F)

ddi_io_get8, ddi_io_get16, ddi_io_get32 - read data from the mapped device register in I/O space

#include <sys/ddi.h>
#include <sys/sunddi.h>
uint8_t ddi_io_get8(ddi_acc_handle_t handle, uint8_t *dev_addr);

uint16_t ddi_io_get16(ddi_acc_handle_t handle, uint16_t  *dev_addr);

uint32_t ddi_io_get32(ddi_acc_handle_t handle, uint32_t  *dev_addr);

illumos DDI specific (illumos DDI). The ddi_io_get8(), ddi_io_get16(), ddi_io_get32(), ddi_io_getb(), ddi_io_getl(), and ddi_io_getw() functions are obsolete. The ddi_get8(9F) function replaces ddi_io_get8(). The ddi_get16(9F) function replaces ddi_io_get16(). The ddi_get32(9F) function replaces ddi_io_get32().

handle

Data access handle returned from setup calls, such as ddi_regs_map_setup(9F).

dev_addr

Device address.

These routines generate a read of various sizes from the device address, dev_addr, in I/O space. The ddi_io_get8(), ddi_io_get16(), and ddi_io_get32() functions read 8 bits, 16 bits, and 32 bits of data, respectively, from the device address, dev_addr.

Each individual datum will automatically be translated to maintain a consistent view between the host and the device based on the encoded information in the data access handle. The translation may involve byte-swapping if the host and the device have incompatible endian characteristics.

These functions can be called from user, kernel, or interrupt context.

See attributes(7) for descriptions of the following attributes:

ATTRIBUTE TYPE ATTRIBUTE VALUE
Interface Stability Obsolete

isa(5), ddi_get16(9F), ddi_get32(9F), ddi_get8(9F), ddi_io_put8(9F), ddi_io_rep_get8(9F), ddi_io_rep_put8(9F), ddi_regs_map_free(9F), ddi_regs_map_setup(9F), ddi_device_acc_attr(9S)

November 1, 2005 OmniOS