DDI_FM_SERVICE_IMPACT(9F) Kernel Functions for Drivers DDI_FM_SERVICE_IMPACT(9F)

ddi_fm_service_impact - report the impact of an error

#include <sys/ddifm.h>
void ddi_fm_service_impact(dev_info_t *dip, int impact);

illumos DDI specific (illumos DDI)

dip

Pointer to the dev_info structure

impact

Impact of error

The following service impact values are accepted by ddi_fm_service_impact():

DDI_SERVICE_LOST

The service provided by the device is unavailable due to an error. The operational state of the device will transition to DEVI_DEVICE_DOWN.

DDI_SERVICE_DEGRADED

The driver is unable to provide normal service, but it can provide a partial or degraded level of service. The driver might have to make repeated attempts to perform an operation before it succeeds, or it may be running at less than its configured speed. A driver may use this value to indicate that an alternative device should be used if available, but that it can continue operation if no alternative exists. The operational state of the device will transition to DEVI_DEVICE_DEGRADED.

DDI_SERVICE_RESTORED

The service provided by the device has been restored. The operational state of the device will transition to its pre-error condition state and DEVI_DEVICE_DOWN or DEVI_DEVICE_DEGRADED is removed.

DDI_SERVICE_UNAFFECTED

The service provided by the device was unaffected by the error.

The ddi_fm_service_impact() function can be called from user, kernel, or high-level interrupt context.

See attributes(7) for descriptions of the following attributes:

ATTRIBUTE TYPE ATTRIBUTE VALUE
Interface Stability Committed

attributes(7), fmd(8), ddi_fm_ereport_post(9F), pci_ereport_post(9F)

March 13, 2016 OmniOS