DDI_FM_INIT(9F) | Kernel Functions for Drivers | DDI_FM_INIT(9F) |
ddi_fm_init, ddi_fm_fini, ddi_fm_capable - initialize and get the FM capabilities for a device instance
#include <sys/ddifm.h> void ddi_fm_init(dev_info_t *dip, int *fm_capability,
ddi_iblock_cookie_t *ibcp);
void ddi_fm_fini(dev_info_t *dip);
int ddi_fm_capable(dev_info_t *dip);
illumos DDI specific (illumos DDI)
ddi_fm_init()
dip
fm_capability
ibcp
A device driver can declare its fault management capabilities to the I/O Fault Management framework by calling ddi_fm_init(). The ddi_fm_init() function allocates and initializes resources according to the bitwise-inclusive-OR of the fault management capabilities, described in the following and supported by the driver's immediate nexus parent.
DDI_FM_NOT_CAPABLE
DDI_FM_EREPORT_CAPABLE
DDI_FM_ACCCHK_CAPABLE
DDI_FM_DMACHK_CAPABLE
DDI_FM_ERRCB_CAPABLE
If the parent nexus is not capable of supporting any one of the requested capabilities, the associated bit will not be set and returned as such to the driver. Before returning from ddi_fm_init(), the I/O Fault Management framework creates a set of fault management capability properties: fm-ereport-capable, fm-errcb-capable, fm-accchk-capable, and fm-dmachk-capable. The current supported fault management capability levels are observable via prtconf(8).
A driver can support the administrative selection of fault management capabilities by exporting and setting a fault management capability level property in its driver.conf(5) file to the values described above. The fm_capable properties must be set and read prior to calling ddi_fm_init() with the desired capability list.
ddi_fm_fini()
ddi_fm_capable()
These functions can be called from kernel context in a driver attach(9E) or detach(9E) operation.
See attributes(7) for descriptions of the following attributes:
ATTRIBUTE TYPE | ATTRIBUTE VALUE |
Interface Stability | Committed |
driver.conf(5), attributes(7), prtconf(8), attach(9E), detach(9E)
Writing Device Drivers
August 8, 2022 | OmniOS |