DDI_FM_ACC_ERR_CLEAR(9F) | Kernel Functions for Drivers | DDI_FM_ACC_ERR_CLEAR(9F) |
ddi_fm_acc_err_clear, ddi_fm_dma_err_clear - clear the error status for an access or DMA handle
#include <sys/ddifm.h> void ddi_fm_acc_err_clear(ddi_acc_handle_t acc_handle,
int version);
void ddi_fm_dma_err_clear(ddi_dma_handle_t dma_handle,
int version);
illumos DDI specific (illumos DDI)
acc_handle
dma_handle
version
The ddi_fm_dma_err_clear() and ddi_fm_acc_err_clear() functions clear the error status of a DMA or access handle respectively.
Once cleared, the driver is again able to access the mapped registers or memory using programmed I/O through the handle.
See attributes(7) for descriptions of the following attributes:
ATTRIBUTE TYPE | ATTRIBUTE VALUE |
Interface Stability | Committed |
attributes(7), ddi_dma_mem_alloc(9F), ddi_fm_acc_err_get(9F), ddi_fm_dma_err_get(9F), ddi_regs_map_setup(9F)
Writing Device Drivers
June 19, 2021 | OmniOS |