POWER(9E) Driver Entry Points POWER(9E)

power - power a device attached to the system

#include <sys/ddi.h>
#include <sys/sunddi.h>
int prefixpower(dev_info_t *dip, int component, int level);

illumos DDI specific (illumos DDI). This entry point is required. If the driver writer does not supply this entry point, the value NULL must be used in the dev_ops(9S) structure instead.

dip

Pointer to the device's dev_info structure.

component

Component of the driver to be managed.

level

Desired component power level.

The power(9E) function is the device-specific Power Management entry point. This function is called when the system wants the driver to set the power level of component to level.

The level argument is the driver-defined power level to which the component needs to be set. Except for power level 0, which is interpreted by the framework to mean "powered off," the interpretation of level is entirely up to the driver.

The component argument is the component of the device to be power-managed. The interpretation of component is entirely up to the driver.

When a requested power transition would cause the device to lose state, the driver must save the state of the device in memory. When a requested power transition requires state to be restored, the driver must restore that state.

If a requested power transition for one component requires another component to change power state before it can be completed, the driver must call pm_raise_power(9F) to get the other component changed, and the power(9E) entry point must support being re-entered.

If the system requests an inappropriate power transition for the device (for example, a request to power down a device which has just become busy), then the power level should not be changed and power should return DDI_FAILURE.

The power() function returns:

DDI_SUCCESS

Successfully set the power to the requested level.

DDI_FAILURE

Failed to set the power to the requested level.

The power() function is called from user or kernel context only.

See attributes(7) for descriptions of the following attributes:

ATTRIBUTE TYPE ATTRIBUTE VALUE
Interface stability Committed

attach(9E), detach(9E), pm_busy_component(9F), pm_idle_component(9F), pm_raise_power(9F), dev_ops(9S)

Writing Device Drivers

Using Power Management

September 16, 2016 OmniOS