|SLPD(8)||Maintenance Commands and Procedures||SLPD(8)|
/usr/lib/inet/slpd [-f configuration-file]
The slpd daemon provides common server functionality for the Service Location Protocol ("SLP") versions 1 and 2, as defined by IETF in RFC 2165 and RFC 2608. SLP provides a scalable framework for the discovery and selection of network services.
slpd provides the following framework services:
Service Agent Server
Passive Directory Agent Discovery
All configuration options are available from the configuration file. slpd reads its configuration file upon startup.
Stop and start the slpd daemon using svcadm(8). Use the command svcadm enable network/slp to start the slpd daemon. Use the command svcadm disable network/slp to stop it.
The file /etc/inet/slp.conf must exist before the slp service can start the daemon. Only the example file /etc/inet/slp.conf.example is present by default. To enable SLP, copy /etc/inet/slp.conf.example to /etc/inet/slp.conf.
The following options are supported:
The following command stops the slpd daemon:
example# svcadm disable network/slp
Example 2 Restarting the slpd daemon
The following command restarts the slpd daemon:
example# svcadm restart network/slp
See attributes(7) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
Guttman, E., Perkins, C., Veizades, J., and Day, M., RFC 2608, Service Location Protocol, Version 2, The Internet Society, June 1999.
The slpd service is managed by the service management facility, smf(7), under the service identifier:
|August 23, 2004||OmniOS|