|INITYP2L(8)||Maintenance Commands and Procedures||INITYP2L(8)|
/usr/lib/netsvc/yp/inityp2l [-m mapping_file_name] [-c config_file_name]
The inityp2l utility assists with creation of the NISLDAPmapping and ypserv files. See NISLDAPmapping(5) and ypserv(5). inityp2l examines the NIS maps on a system. and through a dialogue with the user, determines which NIS to (and from) LDAP mappings are required. A NISLDAPmapping file is then created based on this information. The utility asks users about their LDAP server configuration and a ypserv file is created based on this information.
The inityp2l utility handles mappings for standard NIS maps and the auto.* series of maps. If requested, it creates default mappings for custom maps, with each map entry represented as a single DIT string. inityp2l does not handle full custom mapping, but if requested, inityp2l will insert comments into the NISLDAPmapping file that indicate where these should be added.
To write to the NISLDAPmapping or ypserv files is potentially dangerous. inityp2l warns the user and asks for confirmation before:
inityp2l assists with rapid creation of a simple N2L configuration files. It is not a general purpose tool for the management of these files. An advanced user who would like to maintain the files or use custom mappings should examine the output of inityp2l and customize it by using a standard text editor.
inityp2l supports the following options:
See attributes(7) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
|April 10, 2003||OmniOS|