|DISKSCAN(8)||Maintenance Commands and Procedures||DISKSCAN(8)|
diskscan - perform surface analysis
diskscan [-W] [-n] [-y] raw_device
diskscan is used by the system administrator to perform surface analysis on a portion of a hard disk. The disk portion may be a raw partition or slice; it is identified using its raw device name. By default, the specified portion of the disk is read (non-destructive) and errors reported on standard error. In addition, a progress report is printed on standard out. The list of bad blocks should be saved in a file and later fed into addbadsec(8), which will remap them.
The following options are supported:
The following operands are supported:
The raw device should be /dev/rdsk/c?[t?]d?[ps]?. See disks(8) for an explanation of SCSI and IDE device naming conventions.
See attributes(7) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
The format(8) utility is available to format, label, analyze, and repair SCSI disks. This utility is included with the diskscan, addbadsec(8), fdisk(8), and fmthard(8) commands available for x86. To format an IDE disk, use the DOS format utility; however, to label, analyze, or repair IDE disks on x86 systems, use the Solaris format(8) utility.
|February 24, 1998||OmniOS|