USB_MID(4D) Devices USB_MID(4D)

usb_mid - USB Multi Interface Driver

device@unit-address

The usb_mid driver is a USBA (Solaris Universal Serial Bus Architecture)-compliant nexus driver that binds to device level nodes of a composite (multi interface) device if no vendor or class-specific driver is available. The usb_mid driver creates interface nodes or interface association nodes and attempts to bind drivers to them. If no driver is found for interface association nodes, usb_ia(4D) is bound by default.

The usb_mid driver also supports a ugen(4D) interface allowing raw access to the device, for example by libusb applications, by passing the drivers bound to each interface. Since a libusb application might change the state of the device, you should not access the device through the child interface drivers. Note that the usb_mid driver creates a ugen interface only if none of its children are explicitly bound to the ugen(4D) driver. Additionally, usb_mid does not create children.

/kernel/drv/usb_mid

32-bit x86 ELF kernel module

/kernel/drv/amd64/usb_mid

64-bit x86 ELF kernel module

/kernel/drv/sparcv9/usb_mid

64-bit SPARC ELF kernel module

/dev/usb/*/*/*

ugen(4D) nodes.

See attributes(7) for descriptions of the following attributes:

ATTRIBUTE TYPE ATTRIBUTE VALUE
Architecture SPARC & x86, PCI-based systems

usb_ia(4D), usba(4D), attributes(7), cfgadm_usb(8)

Writing Device Drivers

Universal Serial Bus Specification 2.0—2000

Interface Association Descriptor Engineering Change Notice (ECN)—2003

System Administration Guide: Basic Administration

In addition to being logged, the following messages may appear on the system console. All messages are formatted in the following manner:


Warning: <device path> (usb_mid<instance number>): Error Message...

Cannot access <device>. Please reconnect.

This device has been disconnected because a device other than the original one has been inserted. The driver informs you of this fact by displaying the name of the original device.

Device not identical to the previous one on this port. Please disconnect and reconnect.

Same condition as described above; however in this case, the driver is unable to identify the original device with a name string.

Please disconnect and reconnect this device.

A hotplug of the device is needed before it can be restored.

The following messages may be logged into the system log. They are formatted in the following manner:


<device path><usb_mid<instance number>): message...

No driver found for interface <n> (nodename: <string>) of <device>.

No driver is available for this interface.

No driver found for device <device>.

No driver is available for this interface.

Can't support ugen for multiple configuration devices that have attached child interface drivers.

No ugen interface is available and libusb cannot work with this device.

May 13, 2017 OmniOS