|SENDMAIL(5)||File Formats and Configurations||SENDMAIL(5)|
sendmail, sendmail.cf, submit.cf - sendmail configuration files
The sendmail.cf and submit.cf files are the configuration files for sendmail(8). Starting with version 8.12 of sendmail, which was shipped with version 9 of the Solaris operating system, two configuration files are used for submission and transmission of mail, instead of only sendmail.cf, as before. These are:
The MSP does not require root privileges, thus the two-file model provides better security than the pre-sendmail 8.12 model, in which the MSP ran as a daemon and required root privileges.
In the default sendmail configuration, sendmail uses submit.cf, as indicated in ps(1) output. In ps output, you will observe two sendmail invocations, such as the ones below:
/usr/lib/sendmail -Ac -q15m /usr/lib/sendmail -bd -q15m
The first indicates the use of submit.cf, with the client queue (/var/spool/clientmqueue) being checked—and, if needed, flushed—every 15 minutes. The second invocation runs sendmail as a daemon, waiting for incoming SMTP connections.
As shipped, sendmail.cf and, in particular, submit.cf, are appropriate for most environments. Where a knowledgeable system administrator needs to make a change, he should use the following procedures.
# cd /etc/mail/cf/cf
# cp sendmail.mc `hostname`.mc
# /usr/bin/make `hostname`.cf
# cp `hostname`.cf /etc/mail/sendmail.cf
# svcadm restart sendmail
You must restart sendmail for sendmail.cf file changes to take effect, as indicated in step 6. Steps 4 - 6 can be automated. See Automated Rebuilding of Configuration Files below.
# cd /etc/mail/cf/cf
# cp submit.mc submit-`hostname`.mc
# /usr/bin/make submit-`hostname`.cf
# cp submit-`hostname`.cf /etc/mail/submit.cf
You do not need to restart sendmail for changes to submit.cf to take effect. Steps 4 and 5 can be automated. See Automated Rebuilding of Configuration Files below.
The sendmail(8) man page describes how the config/local_only property can be set to true or false to disallow or allow, respectively, access to remote clients for unmodified systems.
Setting values for the following properties for the service instance svc:/network/smtp:sendmail results in automated (re)building of configuration files:
The values for these properties should be strings which represent the path name of the .mc files referred to in steps 2 and 3 of both procedures above. Recommended values are:
Each property, if set, results in the corresponding .mc file being used to (re)build the matching .cf file when the service is started.
These properties persist across updates. To prevent an update from clobbering your .cf file, or renaming it to .cf.old, you can set the desired properties instead.
See attributes(7) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
System Administration Guide: Network Services
|May 13, 2017||OmniOS|