|HBA.CONF(5)||File Formats and Configurations||HBA.CONF(5)|
hba.conf - configuration file for the HBAAPI library
The /etc/hba.conf file is used to specify the Vendor-Specific Libraries that are installed on the system. This file is used by the Common Library to load the individual VSLs when HBA_LoadLibrary(3HBAAPI) is called. If changes are made to the file while the library is in use, the library should be freed and reloaded. A version 1 VSL is compatible only with a version 1 Common Library. A version 2 VSL is compatible with both a version 1 and a version 2 Common Library.
Each VSL entry is a single line of the form:
"name" "library path"
Example 1 Contents of /etc/hba.conf
# # This file contains names and references to HBA libraries # # Format: # # <library name> <library pathname> # # The library name should be prepended with the domain of # the manufacturer or driver author. com.sun.fchba32 /usr/lib/libsun_fc.so.1 com.sun.fchba64 /usr/lib/sparcv9/libsun_fc.so.1
See attributes(7) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
|Interface Stability||Standard: FC-MI 1.92 (API version 1)|
|Standard: FC-HBA Version 4 (API version 2)|
The HBAAPI is provided in both 32- and 64-bit versions, but only one configuration file is specified. As a result, both 32- and 64-bit VSL libraries must be specified within the same file. When using the 32-bit Common Library, the 64-bit VSLs will fail to load. When using the 64-bit Common Library, the 32-bit VSLs will fail to load. These failures are silently ignored by the Common Library during normal usage, but can result in warning messages when running client applications in a debugger.
|September 4, 2003||OmniOS|