|CONTENTS(5)||File Formats and Configurations||CONTENTS(5)|
contents - list of files and associated packages
The file /var/sadm/install/contents is a source of information about the packages installed on the system. This file must never be edited directly. Always use the package commands (see SEE ALSO) to make changes to the contents file.
Each entry in the contents file is a single line. Fields in each entry are separated by a single space character.
Two major styles of entries exist, old style and new style. The following is the format of an old-style entry:
ftype class path package(s)
The following is the general format of a new-style entry:
path[=rpath] ftype class [ftype-optional-fields] package(s)
New-style entries differ for each ftype. The ftype designates the entry type, as specified in pkgmap(5). The format for new-style entries, for each ftype, is as follows:
ftype s: path=rpath s class package ftype l: path l class package ftype d: path d class mode owner group package(s) ftype b: path b class major minor mode owner group package ftype c: path c class major minor mode owner group package ftype f: path f class mode owner group size cksum modtime package ftype x: path x class mode owner group package ftype v: path v class mode owner group size cksum modtime package ftype e: path e class mode owner group size cksum modtime package
A significant distinction between old- and new-style entries is that the former do not begin with a slash (/) character, while the latter (new-style) always do. For example, the following are old-style entries:
d none /dev SUNWcsd e passwd /etc/passwd SUNWcsr
The following are new-style entries:
/dev d none 0755 root sys SUNWcsr SUNWcsd /etc/passwd e passwd 0644 root sys 580 48299 1077177419 SUNWcsr
The following are the descriptions of the fields in both old- and new-style entries.
See attributes(7) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
As shown above, the interface stability of /var/sadm/install/contents is Unstable (see attributes(7)). It is common practice to use this file in a read-only manner to determine which files belong to which packages installed on a system. While this file has been present for many releases of the Solaris operating system, it might not be present in future releases. The fully supported way to obtain information from the installed package database is through pkgchk(8). It is highly recommended that you use pkgchk rather than relying on the contents file.
|December 20, 2007||OmniOS|