The usbsprl driver is a loadable STREAMS and USBA (Solaris USB architecture) compliant client driver that provides basic asynchronous communication support for Prolific PL2303 USB-to-serial converters. Supported devices include PL2303H, PL2303HX and PL2303X. Serial device streams are built with appropriate modules that are pushed atop the usbsprl driver by the autopush(8) facility.
The usbsprl module supports the termio(4I) device control functions specified by flags in the c_cflag word of the termios structure, and by the IGNBRK, IGNPAR, PARMRK and INPCK flags in the c_iflag word of the termios structure. All other termio(4I) functions must be performed by STREAMS modules pushed atop the driver. When a device is opened, the ldterm(4M) and ttcompat(4M) STREAMS modules are automatically pushed on top of the stream, providing the standard termio(4I) interface.
Use device logical names /dev/term/[0-9]* to access the serial ports. These names are typically used to provide a logical access point for a dial-in line that is used with a modem.
A special feature (controlled by the minor device number) is available that enables a single tty line to be connected to a modem and used for incoming and outgoing calls. By accessing through device logical name /dev/cua/[0-9]*, you can open a port without the carrier detect signal being asserted, either through hardware or an equivalent software mechanism. These devices are commonly known as 'dial-out' lines.
A dial-in line can be opened only if the corresponding dial-out line is closed. A blocking /dev/term open waits until the /dev/cua line is closed (which drops Data Terminal Ready, after which Carrier Detect usually drops as well) and carrier is detected again. A non-blocking /dev/term open returns an error if the /dev/cua is open.
If the /dev/term line is opened successfully (usually only when carrier is recognized on the modem), the corresponding /dev/cua line cannot be opened. This allows a modem and port to be used for dial-in (by enabling the line for login in /etc/inittab) or dial-out (by tip(1), or uucp(1C)) when no one is logged in on the line.
Device hot-removal is functionally equivalent to a modem disconnect event, as defined in termio(4I).
The usbsprl driver supports the standard set of termio(4I) ioctl calls.
Input and output line speeds can be set to the following baud rates: 75, 150, 300, 600, 1200, 1800, 2400, 4800, 9600, 19200, 38400, 57600, 115200, 230400 or 460800. Input and output line speeds cannot be set independently. For example, when the output speed is set, the input speed is automatically set to the same speed.
An open() fails under the following conditions:
See attributes(7) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
|Architecture||SPARC, x86, PCI-based systems|
strconf(1), tip(1), uucp(1C), ioctl(2), open(2), termios(3C), usba(4D), termio(4I), ldterm(4M), ttcompat(4M), attributes(7), autopush(8)
In addition to being logged, the following messages may appear on the system console. All messages are formatted in the following manner:
Warning: <device path> (usbsprl<instance num>): Error Message...
Device was disconnected while open. Data may have been lost.
Device is not identical to the previous one on this port. Please disconnect and reconnect.
Device has been reconnected, but data may have been lost.
Cannot access <device>. Please reconnect.
The following messages may be logged into the system log. They are formatted in the following manner:
<device path><usbsprl<instance number>): message...
|November 23, 2006||OmniOS|