ppdmgr -a ppd_filename_path [-L label] [-R ppd_repository_name] [-w]
ppdmgr -r [-L label] [-R ppd_repository_name]
ppdmgr -u [-L label] [-R ppd_repository_name]
The PPD File Manager adds PPD files to the print system's PPD file repositories. When changes in the PPD file repositories are made by the utility, they are reflected in the Solaris Print Manager (see printmgr(1M)) GUI printer driver field when adding or modifying local attached or network attached printers.
Multiple PPD file repositories may be available. PPD files that are supplied with the system are available in the "system" repository. PPD files that are supplied by third party vendors may be available in the "vendor" repository. PPD files that are supplied by system administrators may be available in the "admin" repository, and PPD files that are added using this utility are available in the "user" repository. When this utility is used to update or rebuild printer information reflected in the printmgr(1M), the special reserved repository name "all" can be used to specify all of the available PPD file repositories.
PPD files are grouped under a user-provided "label" within the print system's PPD file repository to allow easier selection of a printer driver through the printmgr GUI. The special reserved label name "all" can be used to specify all of the available labels in a PPD file repository. The results are undefined if a label name contains characters that are not in the portable filename character set or if a label name starts with a hyphen (-). A label name may not contain a semi-colon (:).
The following subcommand are supported:
The repository name "all" signifies all of the possible repository names. The default repository name is "user". Only the "user" or "admin" repository may be specified with the -a option.
The following commands add a copy of a PPD file to the "user" repository under the "user" label:
# ppdmgr -a /net/somesystem/ppdfiles/ppdfile.ppd
# ppdmgr -a /net/somesystem/ppdfiles/ppdfile.ppd -L user
The following command adds a copy of a PPD file to the "user" repository under the "Photo" label and write the full path of the added copy to standard output:
# ppdmgr -a /net/somesystem/ppdfiles/ppdfile.ppd -L "Photo" -w
Example 2 Updating the cache for the PPD files
The following commands update the cache for the PPD files under the "all" labels in the "user" repository:
# ppdmgr -u
# ppdmgr -u -R user -L all
The following command updates the cache for the PPD files under the "photo" label in the "user" repository:
# ppdmgr -u -R user -L Photo
Example 3 Rebuilding the cache for the PPD files
The following command rebuilds the cache for the PPD files under the "Photo" label in the "user" repository:
# ppdmgr -r -R user -L Photo
The following exit values are returned:
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
|March 9, 2007||OmniOS|