mountall [-F FSType] [-l | -r] [file_system_table]
umountall [-k] [-s] [-F FSType] [-l | -r] [-n] [-Z]
umountall [-k] [-s] [-h host] [-n] [-Z]
mountall is used to mount file systems specified in a file system table. The file system table must be in vfstab(4) format. If no file_system_table is specified, /etc/vfstab is used. If − is specified as file_system_table, mountall reads the file system table from the standard input. mountall mounts only those file systems with the mount at boot field set to yes in the file_system_table.
For each file system in the file system table, the following logic is executed: if there exists a file /usr/lib/fs/FSType/fsckall, where FSType is the type of the file system, save that file system in a list to be passed later, and all at once, as arguments to the /usr/lib/fs/FSType/fsckall script. The /usr/lib/fs/FSType/fsckall script checks all of the file systems in its argument list to determine whether they can be safely mounted. If no /usr/lib/fs/FSType/fsckall script exists for the FSType of the file system, the file system is individually checked using fsck(1M). If the file system does not appear mountable, it is fixed using fsck before the mount is attempted. File systems with a − entry in the fsckdev field are mounted without first being checked.
umountall causes all mounted file systems in the current zone except root, /usr, /var, /var/adm, /var/run, /proc, and /dev/fd to be unmounted. If the FSType is specified, mountall and umountall limit their actions to the FSType specified. There is no guarantee that umountall unmounts busy file systems, even if the -k option is specified.
The following options are supported:
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
No messages are printed if the file systems are mountable and clean.
At this time, NFS is the only remote file system supported by the -l, -r, and -h options.
|December 17, 2008||OmniOS|