fmstat - report fault management module statistics
fmstat [-astTz] [-d u | d ] [-m module] [interval [count]]
The fmstat utility can be used by administrators and service personnel to
report statistics associated with the Fault Manager, fmd(1M) and its
associated set of modules. The Fault Manager runs in the background on each
system. It receives telemetry information relating to problems detected by the
system software, diagnoses these problems, and initiates proactive
self-healing activities such as disabling faulty components.
You can use fmstat to view statistics for diagnosis engines
and agents that are currently participating in fault management. The
documentation for fmd(1M), fmadm(1M), and fmdump(1M)
describes more about tools to observe fault management activities.
If the -m option is present or the -t option is
present, fmstat reports any statistics kept by the specified fault
management module. The module list can be obtained using fmadm
If the -m option is not present, fmstat reports the
following statistics for each of its client modules:
The name of the fault management module, as reported by
The number of telemetry events received by the
The number of events accepted by the module as relevant
to a diagnosis.
The average number of telemetry events waiting to be
examined by the module.
The average service time for telemetry events received by
the module, in milliseconds.
The percentage of time that there were telemetry events
waiting to be examined by the module.
The percentage of time that the module was busy
processing telemetry events.
The number of active cases (open problem investigations)
owned by the module.
The total number of cases solved by this module since it
The amount of dynamic memory currently allocated by this
The amount of persistent buffer space currently allocated
by this module.
The fmstat utility requires the user to possess the
PRIV_SYS_ADMIN privilege. See privileges(5).
The following options are supported:
Print all statistics for a module, including those kept
on its behalf by fmd. If the -a option is not present, only
those statistics kept by the module are reported. If the -a option is
used without the -m module, a set of global statistics
associated with fmd are displayed.
-d u | d
Display a time stamp.
Specify u for a printed representation of the internal
representation of time. See time(2). Specify d for standard
date format. See date(1).
Print a report on the statistics associated with the
specified fault management module, instead of the default statistics report.
Modules can publish an arbitrary set of statistics to help Sun service the
fault management software itself. The module statistics constitute a Private
interface. See attributes(5)
for information on Sun's rules for Private
interfaces. Scripts should not be written that depend upon the values of fault
management module statistics as they can change without notice.
Print a report on Soft Error Rate Discrimination (SERD)
engines associated with the module instead of the default module statistics
report. A SERD engine is a construct used by fault management software to
determine if a statistical threshold measured as N events in some time
T has been exceeded. The -s option can only be used in
combination with the -m option.
Print a report on the statistics associated with each
fault management event transport. Each fault management module can provide the
implementation of one or more event transports.
Print a table of the authority information associated
with each fault management event transport. If the -m option is
present, only transports associated with the specified module are
Omit statistics with a zero value from the report
associated with the specified fault management module. The -z option
can only be used in combination with the -m option.
The following operands are supported:
Print only count reports, and then exit.
Print a new report every interval seconds.
If no interval and no count are specified, a single
report is printed and fmstat exits. If an interval is
specified but no count is specified, fmstat prints reports
every interval seconds indefinitely until the command is
The following exit values are returned:
A fatal error occurred. A fatal error could be the
failure to communicate with fmd(1M)
. It could also be that insufficient
privileges were available to perform the requested operation.
Invalid command-line options were specified.
See attributes(5) for descriptions of the following attributes:
The command-line options are Evolving. The human-readable default
report is Unstable. The human-readable module report is Private.