|MKFS_PCFS(8)||Maintenance Commands and Procedures||MKFS_PCFS(8)|
mkfs -F pcfs [generic_options] [-o FSType_specific_options] raw_device_file
The pcfs-specific module of mkfs constructs a File Allocation Table (FAT) on removable media (diskette, JAZ disk, ZIP disk, PCMCIA card), a hard disk, or a file (see NOTES). FATs are the standard MS-DOS and Windows file system format. Note that you can use fdformat(1) to construct a FAT file system only on a diskette or PCMCIA card.
mkfs for pcfs determines an appropriate FAT size for the medium, then it installs an initial boot sector and an empty FAT. A sector size of 512 bytes is used. mkfs for pcfs can also install the initial file in the file system (see the pcfs-specific -o i option). This first file can optionally be marked as read-only, system, and/or hidden.
If you want to construct a FAT with mkfs for pcfs on a medium that is not formatted, you must first perform a low-level format on the medium with fdformat(1) or format(8). Non-diskette media must also be partitioned with the fdisk(8) utility. Note that all existing data on the diskette or disk partition, if any, is destroyed when a new FAT is constructed.
generic_options are supported by the generic mkfs command. See mkfs(8) for a description of these options.
raw_device_file indicates the device on which to write unless the -o N option has been specified, or if the -V or -m generic options are passed from the generic mkfs module.
See mkfs(8) for the list of supported generic options.
The following options are supported:
For a file, raw_device_file is the block device name returned by lofiadm(8).
The media in these examples must be formatted before running mkfs for pcfs. See DESCRIPTION for more details.
Example 1 Creating a FAT File System on a Diskette
The following command creates a FAT file system on a diskette:
mkfs -F pcfs /dev/rdiskette
Example 2 Creating a FAT File System on a Disk
The following command creates a FAT file system on the second fdisk partition of a disk attached to an x86 based system:
mkfs -F pcfs /dev/rdsk/c0d0p0:d
Example 3 Creating a FAT File System on a ZIP Disk
The following command creates a FAT file system on a ZIP disk located on a SPARC based system:
mkfs -F pcfs /dev/rdsk/c0t4d0s2:c
Example 4 Creating a FAT File System on a JAZ Disk
The following command creates a FAT file system on a JAZ disk located on a SPARC based system and overrides the sectors/track and tracks/cylinder values obtained from the device's controller:
mkfs -F pcfs -o nsect=32,ntrack=64 /dev/rdsk/c0t3d0s2:c
See attributes(7) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
The default MS-DOS boot loader, which is installed by default if -o B is not specified, requires specific MS-DOS system files to make the diskette bootable. These MS-DOS files are not installed when you format a diskette with mkfs for pcfs, which makes a diskette formatted this way not bootable. Trying to boot from it on an x86 based system will result in the following message:
Non-System disk or disk error Replace and strike any key when ready
You must format a diskette with the DOS format command to install the specific MS-DOS system files required by the default boot loader.
You can use lofiadm to create a file that appears to a mkfs command (for example, mkfs_pcfs or mkfs_ufs) as a raw device. You can then use a mkfs command to create a file system on that device. See lofiadm(8) for examples of creating a UFS and a PC (FAT) file system on a device created by lofiadm.
|December 1, 2003||OmniOS|